Bug 23239 - install.pl: DBD::mysql::st execute failed: Incorrect integer value
Summary: install.pl: DBD::mysql::st execute failed: Incorrect integer value
Status: RESOLVED DUPLICATE of bug 22919
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (web-based installer) (show other bugs)
Version: 19.05
Hardware: PC Linux
: P5 - low minor (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-01 08:09 UTC by Martin Holmes
Modified: 2019-11-20 15:11 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Holmes 2019-07-01 08:09:59 UTC
I'm using Koha 19.0500000 from Koha official PPA. The DB server that I use is latest Maria BD 10.4 from their official PPA. During MARC 21 setup, I get this error:

[Mon Jul 1 07:12:57 2019] install.pl: DBD::mysql::st execute failed: Incorrect integer value: '' for column `koha_library`.`auth_subfield_structure`.`linkid` at row 148 at /usr/share/perl5/DBIx/RunSQL.pm line 273. 

But, installation completes successfully. Is this a serious error? How can I prevent it?
Comment 1 Javier 2019-07-24 14:11:59 UTC
I can reproduce the issue with Koha 18.11.05-1 and MariaDB 10.2.10:

ii  koha-common                            18.11.05-1                   all          integrated (physical) library management system

mysql  Ver 15.1 Distrib 10.2.10-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2
Comment 2 Javier 2019-07-24 14:38:33 UTC
Fix: use MariaDB 10.1.40

Snippet of docker-compose file:

----------------------------------------------------------------------
version: '3.7'

services:

  koha-db:
    container_name: koha-db
    # issue: install.pl: DBD::mysql::st execute failed: Incorrect integer value (edit) 
    #image: mariadb
    #image: mariadb:10.0.15
    image: mariadb:10.1
    environment:
      MYSQL_ROOT_PASSWORD: koha

  koha:
    container_name: koha
    image: kedu/koha-community
    cap_add:
        - SYS_NICE
        - DAC_READ_SEARCH
    depends_on:
        - koha-db
    environment:
      LIBRARY_NAME: koha
      SLEEP: 3
      INTRAPORT: 8080
      DB_HOST: koha-db
      DB_ROOT_PASSWORD: koha
    ports:
      - "80:80"
      - "8080:8080"
----------------------------------------------------------------------
Comment 3 Jonathan Druart 2019-11-20 15:11:45 UTC
Fixed on bug 22919.

*** This bug has been marked as a duplicate of bug 22919 ***