Bug 23442 - Add a 'refund' process to accounts
Summary: Add a 'refund' process to accounts
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Fines and fees (show other bugs)
Version: master
Hardware: All All
: P5 - low new feature (vote)
Assignee: Martin Renvoize
QA Contact: Josef Moravec
URL:
Keywords:
: 24248 (view as bug list)
Depends on: 24255
Blocks: 24081 24849 24952 26403 26418 23354
  Show dependency treegraph
 
Reported: 2019-08-09 08:13 UTC by Martin Renvoize
Modified: 2020-09-09 14:20 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
This enhancement adds a workflow that allows staff with the new `refund` permission to refund/reimburse patrons when they have been incorrectly charged for a transaction. It records an audit trail for the process.
Version(s) released in:
20.05.00


Attachments
Bug 23442: Add a refund option to POS (23.65 KB, patch)
2019-09-18 15:00 UTC, Martin Renvoize
Details | Diff | Splinter Review
Accounttype Translations (1.09 KB, patch)
2019-09-18 15:00 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23445: Add previous transactions option (10.67 KB, patch)
2019-09-18 15:00 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add account credit types (1.81 KB, patch)
2019-11-21 16:14 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add 'reduce' method to Koha::Account::Line (4.78 KB, patch)
2019-11-21 16:14 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add refund permission (2.89 KB, patch)
2019-11-21 16:14 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add refund option to patron account page (9.40 KB, patch)
2019-11-21 16:14 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add account credit types (2.52 KB, patch)
2019-12-18 08:52 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add 'reduce' method to Koha::Account::Line (12.06 KB, patch)
2019-12-18 08:52 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add refund permission (3.09 KB, patch)
2019-12-18 08:52 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add refund option to patron account page (9.50 KB, patch)
2019-12-18 08:52 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add account credit types (2.52 KB, patch)
2019-12-18 12:40 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add 'reduce' method to Koha::Account::Line (12.06 KB, patch)
2019-12-18 12:40 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add refund permission (3.09 KB, patch)
2019-12-18 12:40 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add refund option to patron account page (9.50 KB, patch)
2019-12-18 12:40 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add account credit types (2.59 KB, patch)
2020-01-08 15:53 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 23442: Add 'reduce' method to Koha::Account::Line (12.13 KB, patch)
2020-01-08 15:53 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 23442: Add refund permission (3.16 KB, patch)
2020-01-08 15:53 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 23442: Add refund option to patron account page (9.57 KB, patch)
2020-01-08 15:53 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 23442: Add html filter to a couple lines in template (1.66 KB, patch)
2020-01-08 15:53 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 23442: Add account credit types (2.39 KB, patch)
2020-01-09 12:03 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add 'reduce' method to Koha::Account::Line (12.06 KB, patch)
2020-01-09 12:03 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add refund permission (3.11 KB, patch)
2020-01-09 12:03 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add refund option to patron account page (9.56 KB, patch)
2020-01-09 12:03 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add html filter to a couple lines in template (1.64 KB, patch)
2020-01-09 12:03 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Prevent payouts from being reduced (7.07 KB, patch)
2020-01-09 12:03 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23442: Add account credit types (2.45 KB, patch)
2020-01-10 07:44 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 23442: Add 'reduce' method to Koha::Account::Line (12.13 KB, patch)
2020-01-10 07:44 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 23442: Add refund permission (3.16 KB, patch)
2020-01-10 07:45 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 23442: Add refund option to patron account page (9.63 KB, patch)
2020-01-10 07:45 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 23442: Add html filter to a couple lines in template (1.70 KB, patch)
2020-01-10 07:46 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 23442: Prevent payouts from being reduced (7.14 KB, patch)
2020-01-10 07:46 UTC, Josef Moravec
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Renvoize 2019-08-09 08:13:57 UTC
Bug 23354 adds a 'Pay' screen as the beginning of a 'Point of Sale' system. Currently, it only allows for payment of items, but there are occasions where librarians may need to issue a refund.
Comment 1 Martin Renvoize 2019-09-18 15:00:31 UTC
Created attachment 92954 [details] [review]
Bug 23442: Add a refund option to POS
Comment 2 Martin Renvoize 2019-09-18 15:00:34 UTC
Created attachment 92955 [details] [review]
Accounttype Translations
Comment 3 Martin Renvoize 2019-09-18 15:00:37 UTC
Created attachment 92956 [details] [review]
Bug 23445: Add previous transactions option
Comment 4 Martin Renvoize 2019-11-21 16:14:34 UTC
Created attachment 95674 [details] [review]
Bug 23442: Add account credit types
Comment 5 Martin Renvoize 2019-11-21 16:14:37 UTC
Created attachment 95675 [details] [review]
Bug 23442: Add 'reduce' method to Koha::Account::Line

This enhancement adds a 'reduce' method to Koha::Account::Line which can
be used to reduce a charge/debit by adding a credit to offset against
the amount outstanding.

It may be used to apply a discount whilst retaining the original debit
amounts or to apply a full or partial refund for example when a lost
item is found and returned.

The created credit will be immediately applied against the debit unless
the debit has already been paid, in which case a 'zero' offset will be
added to maintain a link to the debit but the outstanding credit will be
left so it may be applied to other debts.

Test Plan:
1) Run the included tests and verify they pass.
2) Signoff
Comment 6 Martin Renvoize 2019-11-21 16:14:40 UTC
Created attachment 95676 [details] [review]
Bug 23442: Add refund permission

Add a new subpermission called 'refund' to the 'updatecharges'
permission group which will allow/prevent refund actions to be
performed by staff.
Comment 7 Martin Renvoize 2019-11-21 16:14:44 UTC
Created attachment 95677 [details] [review]
Bug 23442: Add refund option to patron account page

This enhancement adds a refined workflow to allow librarians
to refund payments to patrons and record these refunds on the
patrons account.

The use case is that a patron has paid for something before
then performing an action that may require some level of refund
to be actioned.  Perhaps they are returning a lost and paid for
book.

Test plan:
1) Undertake a series of transactions that result in a debit
   accountline being partially or fully paid off.
2) Note that a new 'Issue refund' button appears next to a
   debit (but only if your user has the refund permission or
   is a superlibrarian)
3) Click the 'Issue refund' button and a modal should appear
   pre-populated with the amount - amountoutstanding.
4) You should be able to edit the amount you wish to refund,
   record the refund or cancel.
5) Signoff
Comment 8 Martin Renvoize 2019-12-17 16:24:33 UTC
*** Bug 24248 has been marked as a duplicate of this bug. ***
Comment 9 Martin Renvoize 2019-12-18 08:52:48 UTC
Created attachment 96400 [details] [review]
Bug 23442: Add account credit types
Comment 10 Martin Renvoize 2019-12-18 08:52:51 UTC
Created attachment 96401 [details] [review]
Bug 23442: Add 'reduce' method to Koha::Account::Line

This enhancement adds a 'reduce' method to Koha::Account::Line which can
be used to reduce a charge/debit by adding a credit to offset against
the amount outstanding.

It may be used to apply a discount whilst retaining the original debit
amounts or to apply a full or partial refund for example when a lost
item is found and returned.

The created credit will be immediately applied against the debit unless
the debit has already been paid, in which case a 'zero' offset will be
added to maintain a link to the debit but the outstanding credit will be
left so it may be applied to other debts.

Test Plan:
1) Run the included tests and verify they pass.
2) Signoff
Comment 11 Martin Renvoize 2019-12-18 08:52:54 UTC
Created attachment 96402 [details] [review]
Bug 23442: Add refund permission

Add a new subpermission called 'refund' to the 'updatecharges'
permission group which will allow/prevent refund actions to be
performed by staff.
Comment 12 Martin Renvoize 2019-12-18 08:52:57 UTC
Created attachment 96403 [details] [review]
Bug 23442: Add refund option to patron account page

This enhancement adds a refined workflow to allow librarians
to refund payments to patrons and record these refunds on the
patrons account.

The use case is that a patron has paid for something before
then performing an action that may require some level of refund
to be actioned.  Perhaps they are returning a lost and paid for
book.

Test plan:
1) Undertake a series of transactions that result in a debit
   accountline being partially or fully paid off.
2) Note that a new 'Issue refund' button appears next to a
   debit (but only if your user has the refund permission or
   is a superlibrarian)
3) Click the 'Issue refund' button and a modal should appear
   pre-populated with the amount - amountoutstanding.
4) You should be able to edit the amount you wish to refund,
   record the refund or cancel.
5) Signoff
Comment 13 Martin Renvoize 2019-12-18 12:40:28 UTC
Created attachment 96414 [details] [review]
Bug 23442: Add account credit types
Comment 14 Martin Renvoize 2019-12-18 12:40:31 UTC
Created attachment 96415 [details] [review]
Bug 23442: Add 'reduce' method to Koha::Account::Line

This enhancement adds a 'reduce' method to Koha::Account::Line which can
be used to reduce a charge/debit by adding a credit to offset against
the amount outstanding.

It may be used to apply a discount whilst retaining the original debit
amounts or to apply a full or partial refund for example when a lost
item is found and returned.

The created credit will be immediately applied against the debit unless
the debit has already been paid, in which case a 'zero' offset will be
added to maintain a link to the debit but the outstanding credit will be
left so it may be applied to other debts.

Test Plan:
1) Run the included tests and verify they pass.
2) Signoff
Comment 15 Martin Renvoize 2019-12-18 12:40:34 UTC
Created attachment 96416 [details] [review]
Bug 23442: Add refund permission

Add a new subpermission called 'refund' to the 'updatecharges'
permission group which will allow/prevent refund actions to be
performed by staff.
Comment 16 Martin Renvoize 2019-12-18 12:40:37 UTC
Created attachment 96417 [details] [review]
Bug 23442: Add refund option to patron account page

This enhancement adds a refined workflow to allow librarians
to refund payments to patrons and record these refunds on the
patrons account.

The use case is that a patron has paid for something before
then performing an action that may require some level of refund
to be actioned.  Perhaps they are returning a lost and paid for
book.

Test plan:
1) Undertake a series of transactions that result in a debit
   accountline being partially or fully paid off.
2) Note that a new 'Issue refund' button appears next to a
   debit (but only if your user has the refund permission or
   is a superlibrarian)
3) Click the 'Issue refund' button and a modal should appear
   pre-populated with the amount - amountoutstanding.
4) You should be able to edit the amount you wish to refund,
   record the refund or cancel.
5) Signoff
Comment 17 Michal Denar 2020-01-07 22:22:39 UTC
Hi Martin,
I get error:
{UNKNOWN}: Can't locate object method "payout" via package "Koha::Schema::Result::Accountline" at /home/vagrant/kohaclone/members/boraccount.pl line 139. at /home/vagrant/kohaclone/members/boraccount.pl line 151
 at /usr/share/perl5/DBIx/Class/Exception.pm line 77

    in DBIx::Class::Exception::throw at /usr/share/perl5/DBIx/Class/Exception.pm line 77

Miss I something?
Comment 18 Martin Renvoize 2020-01-08 13:11:58 UTC
Erm, 

I can't replicate that.. did you apply the chain of dependencies and are you running against master?
Comment 19 Michal Denar 2020-01-08 13:44:39 UTC
I'm on masted, all depencies applied. I'll try it again.
Comment 20 Kyle M Hall 2020-01-08 15:53:10 UTC
Created attachment 97008 [details] [review]
Bug 23442: Add account credit types

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 21 Kyle M Hall 2020-01-08 15:53:43 UTC
Created attachment 97009 [details] [review]
Bug 23442: Add 'reduce' method to Koha::Account::Line

This enhancement adds a 'reduce' method to Koha::Account::Line which can
be used to reduce a charge/debit by adding a credit to offset against
the amount outstanding.

It may be used to apply a discount whilst retaining the original debit
amounts or to apply a full or partial refund for example when a lost
item is found and returned.

The created credit will be immediately applied against the debit unless
the debit has already been paid, in which case a 'zero' offset will be
added to maintain a link to the debit but the outstanding credit will be
left so it may be applied to other debts.

Test Plan:
1) Run the included tests and verify they pass.
2) Signoff

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 22 Kyle M Hall 2020-01-08 15:53:46 UTC
Created attachment 97010 [details] [review]
Bug 23442: Add refund permission

Add a new subpermission called 'refund' to the 'updatecharges'
permission group which will allow/prevent refund actions to be
performed by staff.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 23 Kyle M Hall 2020-01-08 15:53:49 UTC
Created attachment 97011 [details] [review]
Bug 23442: Add refund option to patron account page

This enhancement adds a refined workflow to allow librarians
to refund payments to patrons and record these refunds on the
patrons account.

The use case is that a patron has paid for something before
then performing an action that may require some level of refund
to be actioned.  Perhaps they are returning a lost and paid for
book.

Test plan:
1) Undertake a series of transactions that result in a debit
   accountline being partially or fully paid off.
2) Note that a new 'Issue refund' button appears next to a
   debit (but only if your user has the refund permission or
   is a superlibrarian)
3) Click the 'Issue refund' button and a modal should appear
   pre-populated with the amount - amountoutstanding.
4) You should be able to edit the amount you wish to refund,
   record the refund or cancel.
5) Signoff

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 24 Kyle M Hall 2020-01-08 15:53:52 UTC
Created attachment 97012 [details] [review]
Bug 23442: Add html filter to a couple lines in template

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 25 Josef Moravec 2020-01-09 07:22:56 UTC
Comment on attachment 97008 [details] [review]
Bug 23442: Add account credit types

Review of attachment 97008 [details] [review]:
-----------------------------------------------------------------

::: installer/data/mysql/account_offset_types.sql
@@ +17,5 @@
>  ('OVERDUE'),
>  ('Void Payment'),
>  ('Credit Applied'),
> +('PAYOUT'),
> +('DISOUNT'),

Typo: should be 'DISCOUNT'

::: installer/data/mysql/atomicupdate/bug_23442.perl
@@ +15,5 @@
> +    });
> +
> +    SetVersion($DBversion);
> +    print "Upgrade to $DBversion done (Bug 23442 - Add REFUND and DISCOUNT account_credit_types)\n";
> +    print "Upgrade to $DBversion done (Bug 23442 - Add REFUNDED and DISCOUNTED account_offset_types)\n";

Should be 'REFUND' and 'DISCOUNT' too
Comment 26 Josef Moravec 2020-01-09 07:58:50 UTC
Comment on attachment 97011 [details] [review]
Bug 23442: Add refund option to patron account page

Review of attachment 97011 [details] [review]:
-----------------------------------------------------------------

::: koha-tmpl/intranet-tmpl/prog/en/modules/members/boraccount.tt
@@ +216,5 @@
> +                                    <select name="transaction_type" id="transaction_type">
> +                                            <option value="AC">Account credit</option>
> +                                        [% FOREACH pt IN payment_types %]
> +                                            <option value="[% pt.authorised_value | html %]">[% pt.lib | html %]</option>
> +                                        [% END %]

The condition '[% IF payment_types %]' should be just before 'FOREACH' because if you don't have any payment type defined you can't use the hardcoded 'AC' value neither...
Comment 27 Josef Moravec 2020-01-09 08:06:57 UTC
Martin,

you have added also "DISCOUNT" offset and credit type, but don't work with this value in further code, are they added by mistake? Shouldn't be better to add them in patch for bug 24081?


also, try this:
1) Create and pay any fee
2) Refund it
3) On line described as 'A refund applied to a patrons fine' you have options to payout, use it
4) Now you have new line called 'Payment from library to patron' and refund option available on it, use it, confirm -> boom:
Combined reduction (30 + -30) is higher than original amount (30) at /usr/share/perl5/Exception/Class/Base.pm line 88
Comment 28 Martin Renvoize 2020-01-09 08:31:32 UTC
Thanks for testing this Josef.. at least some of the issue look to be the result of various rebases..

I'll clean it up today and test that nasty failure case too.
Comment 29 Martin Renvoize 2020-01-09 12:03:06 UTC
Created attachment 97062 [details] [review]
Bug 23442: Add account credit types

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 30 Martin Renvoize 2020-01-09 12:03:09 UTC
Created attachment 97063 [details] [review]
Bug 23442: Add 'reduce' method to Koha::Account::Line

This enhancement adds a 'reduce' method to Koha::Account::Line which can
be used to reduce a charge/debit by adding a credit to offset against
the amount outstanding.

It may be used to apply a discount whilst retaining the original debit
amounts or to apply a full or partial refund for example when a lost
item is found and returned.

The created credit will be immediately applied against the debit unless
the debit has already been paid, in which case a 'zero' offset will be
added to maintain a link to the debit but the outstanding credit will be
left so it may be applied to other debts.

Test Plan:
1) Run the included tests and verify they pass.
2) Signoff

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 31 Martin Renvoize 2020-01-09 12:03:13 UTC
Created attachment 97064 [details] [review]
Bug 23442: Add refund permission

Add a new subpermission called 'refund' to the 'updatecharges'
permission group which will allow/prevent refund actions to be
performed by staff.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 32 Martin Renvoize 2020-01-09 12:03:17 UTC
Created attachment 97065 [details] [review]
Bug 23442: Add refund option to patron account page

This enhancement adds a refined workflow to allow librarians
to refund payments to patrons and record these refunds on the
patrons account.

The use case is that a patron has paid for something before
then performing an action that may require some level of refund
to be actioned.  Perhaps they are returning a lost and paid for
book.

Test plan:
1) Undertake a series of transactions that result in a debit
   accountline being partially or fully paid off.
2) Note that a new 'Issue refund' button appears next to a
   debit (but only if your user has the refund permission or
   is a superlibrarian)
3) Click the 'Issue refund' button and a modal should appear
   pre-populated with the amount - amountoutstanding.
4) You should be able to edit the amount you wish to refund,
   record the refund or cancel.
5) Signoff

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 33 Martin Renvoize 2020-01-09 12:03:20 UTC
Created attachment 97066 [details] [review]
Bug 23442: Add html filter to a couple lines in template

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 34 Martin Renvoize 2020-01-09 12:03:24 UTC
Created attachment 97067 [details] [review]
Bug 23442: Prevent payouts from being reduced

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 35 Martin Renvoize 2020-01-09 12:05:20 UTC
OK, one followup added and the original patches amended to reflect comments.

I believe we're back in action and ready for a second QA run now Josef.. again, thanks for looking :)
Comment 36 Josef Moravec 2020-01-10 07:44:41 UTC
Created attachment 97151 [details] [review]
Bug 23442: Add account credit types

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 37 Josef Moravec 2020-01-10 07:44:53 UTC
Created attachment 97152 [details] [review]
Bug 23442: Add 'reduce' method to Koha::Account::Line

This enhancement adds a 'reduce' method to Koha::Account::Line which can
be used to reduce a charge/debit by adding a credit to offset against
the amount outstanding.

It may be used to apply a discount whilst retaining the original debit
amounts or to apply a full or partial refund for example when a lost
item is found and returned.

The created credit will be immediately applied against the debit unless
the debit has already been paid, in which case a 'zero' offset will be
added to maintain a link to the debit but the outstanding credit will be
left so it may be applied to other debts.

Test Plan:
1) Run the included tests and verify they pass.
2) Signoff

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 38 Josef Moravec 2020-01-10 07:45:18 UTC
Created attachment 97153 [details] [review]
Bug 23442: Add refund permission

Add a new subpermission called 'refund' to the 'updatecharges'
permission group which will allow/prevent refund actions to be
performed by staff.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 39 Josef Moravec 2020-01-10 07:45:50 UTC
Created attachment 97154 [details] [review]
Bug 23442: Add refund option to patron account page

This enhancement adds a refined workflow to allow librarians
to refund payments to patrons and record these refunds on the
patrons account.

The use case is that a patron has paid for something before
then performing an action that may require some level of refund
to be actioned.  Perhaps they are returning a lost and paid for
book.

Test plan:
1) Undertake a series of transactions that result in a debit
   accountline being partially or fully paid off.
2) Note that a new 'Issue refund' button appears next to a
   debit (but only if your user has the refund permission or
   is a superlibrarian)
3) Click the 'Issue refund' button and a modal should appear
   pre-populated with the amount - amountoutstanding.
4) You should be able to edit the amount you wish to refund,
   record the refund or cancel.
5) Signoff

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 40 Josef Moravec 2020-01-10 07:46:03 UTC
Created attachment 97155 [details] [review]
Bug 23442: Add html filter to a couple lines in template

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 41 Josef Moravec 2020-01-10 07:46:24 UTC
Created attachment 97156 [details] [review]
Bug 23442: Prevent payouts from being reduced

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 42 Josef Moravec 2020-01-10 07:47:56 UTC
Thanks Martin for such quick reaction, Passed QA now ;)
Comment 43 Martin Renvoize 2020-01-10 08:41:50 UTC
Nice work everyone!

Pushed to master for 20.05
Comment 44 Joy Nelson 2020-01-14 00:31:31 UTC
Not backported to 19.11.x