Bug 2349 - Allow CSS customization of circulation receipts
Summary: Allow CSS customization of circulation receipts
Status: CLOSED DUPLICATE of bug 7001
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P2 enhancement (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 6287
  Show dependency treegraph
 
Reported: 2008-07-14 09:42 UTC by Chris Cormack
Modified: 2012-10-26 00:41 UTC (History)
7 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 00:50:09 UTC


---- Reported by jesse.weaver@liblime.com 2008-07-14 09:42:42 ----

 



---- Additional Comments From jesse.weaver@liblime.com 2008-07-14 09:44:15 ----

Andrew Moore and I were discussing customization of circulation slips in #liblime, and decided it might be nice to create a syspref that gives a stylesheet for moremember-print.tmpl, then make the template very inclusive and allow elements to be turned off through CSS.



---- Additional Comments From wizzyrea@gmail.com 2009-03-27 21:04:17 ----

Yes, yes, oh god, yes.

Another thing to consider: slips configurable on a per-branch/library basis so they can put their own address and phone number on the branch receipt.

The receipt printed would be keyed to the branch of the logged in staff user.

Love this idea.



---- Additional Comments From arm@hanover.ca 2009-08-05 23:54:03 ----

More OH, YES! from me.

We have already hacked in to add our library address to the slip. I would love to see this option - to insert branch address (from the branches pref) at head of receipt.
We would also like a short free text area that might be used to remind patrons that the library has an event or will be closed etc.

We would really like to be able to print today's checkouts only - with a system preference to set the default, rather than having to make the choice every time. The drop down list could have full listing and page layout options for those times we do not want to print the default short list.

Also we note that the slip prints oldest at the top and newest at the bottom regardless of the sort order we choose for the display. Surely this should print in the same order as the circulation page display?




--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 00:50 UTC  ---

This bug was previously known as _bug_ 2349 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2349

Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was jesse.weaver@liblime.com.
CC member arm@hanover.ca does not have an account here
CC member bchurch@ptfs.com does not have an account here
CC member bibliwho@gmail.com does not have an account here
CC member jesse.weaver@liblime.com does not have an account here
CC member jwagner@ptfs.com does not have an account here

Comment 1 Katrin Fischer 2011-04-25 09:13:31 UTC
Is this still something people are interested in? Sounds like it would be not too hard to do.
Comment 2 Nicole C. Engard 2011-04-25 11:43:25 UTC
Yes, I have several libraries interested in there. One suggestion I've heard is to put the slips in with the notices and let them be customized that way since merging data from the database is a necessity on receipts.

Nicole
Comment 3 Katrin Fischer 2012-01-06 15:51:07 UTC
I think this can be seen as duplicate of bug 7001:
- html will make it possible to customize to your heart's content
- slips are moved in with notices
- different slips for each branch

*** This bug has been marked as a duplicate of bug 7001 ***