Bug 23655 - Errors when running on Debian Jessie
Summary: Errors when running on Debian Jessie
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Martin Renvoize
QA Contact: Testopia
URL:
Keywords:
: 23850 (view as bug list)
Depends on: 14570
Blocks:
  Show dependency treegraph
 
Reported: 2019-09-20 13:48 UTC by Stefan Berndtsson
Modified: 2019-11-26 17:00 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
19.11.00


Attachments
Bug 23655: Replace selectall_array with selectall_arrayref (1.66 KB, patch)
2019-09-24 12:42 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 23655: Restore debian Jessie support (1.67 KB, patch)
2019-10-26 11:08 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Berndtsson 2019-09-20 13:48:46 UTC
As of Bug 14570, Debian jessie no longer works fully as a distribution. That bug uses the DBI method selectall_array() which was added in DBI version 1.635, but Debian jessie only provides 1.631.

The wiki, and possibly other documentation, still states that jessie is a working environment.

The result of this can be seen on about.pl where it will result in an error with an earlier DBI version.
Comment 1 Katrin Fischer 2019-09-22 11:17:09 UTC
I am not sure if this was intentional - adding Martin as RM.
Comment 2 Martin Renvoize 2019-09-24 12:17:09 UTC
This certainly wasn't deliberate on my part.
Comment 3 Martin Renvoize 2019-09-24 12:42:03 UTC
Created attachment 93138 [details] [review]
Bug 23655: Replace selectall_array with selectall_arrayref

The selectall_array method is introduced in DBI version 1.635 which is
not available in Debian Jessie at time of writing.

This patch replaces it with selectall_arrayref which was introduced in
1.631 and is available by default.
Comment 4 Katrin Fischer 2019-09-30 13:45:39 UTC
Sorry, that's a fail :(

Not an ARRAY reference at /home/vagrant/kohaclone/about.pl line 488
Comment 5 Katrin Fischer 2019-09-30 13:47:24 UTC
Would it be worth adding a check to the QA script to avoid this happening again?
Comment 6 Martin Renvoize 2019-10-26 11:02:08 UTC
ooh.. I thought this had been pushed ages ago.. oops.

This is also the cause of our D8 test failures.
Comment 7 Martin Renvoize 2019-10-26 11:04:28 UTC
The 'Slice' is not required in this case... I've corrected and pushed as I now have the tests passing.

Tip:  You can run tests against various versions using koha-testing-docker by prepending ku with a 'KOHA_IMAGE' param.

`KOHA_IMAGE=master-jessie ku` in this case.
Comment 8 Martin Renvoize 2019-10-26 11:08:19 UTC
Created attachment 94802 [details] [review]
Bug 23655: Restore debian Jessie support

Bug 14570 inadveratntly introduced the use of selectall_array; A feature
that was introduced to DBI version 1.635 which is not available in
debian jessie at the time of writing.

This patch replaces the call with selectall_arrayref which is supported
and works with the rest of the existing code.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 9 Fridolin SOMERS 2019-11-08 15:30:05 UTC
Depends on Bug 14570 not in 19.05.x
Comment 10 Martin Renvoize 2019-11-11 10:15:50 UTC
*** Bug 23850 has been marked as a duplicate of this bug. ***