Bug 2375 - Serials holdings data does not display in opac-detail
Summary: Serials holdings data does not display in opac-detail
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Owen Leonard
QA Contact:
URL:
Whiteboard:
Keywords:
: 3911 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-21 06:33 UTC by Owen Leonard
Modified: 2012-10-25 22:52 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Serial Columns Error Example (234.00 KB, application/msword)
2009-03-11 17:20 UTC, Chris Cormack
Details
Screenshot of the problem (56.54 KB, image/png)
2010-02-05 14:42 UTC, Chris Cormack
Details
Screenshot showing same record with 440 tag removed (56.44 KB, image/png)
2010-02-05 14:44 UTC, Chris Cormack
Details
Proposed fix (2.08 KB, patch)
2010-02-05 15:14 UTC, Chris Cormack
Details | Diff | Splinter Review
Revised fix (older patch no longer applied) (2.08 KB, patch)
2010-05-04 15:15 UTC, Chris Cormack
Details | Diff | Splinter Review
Revised fix (older patch no longer applied) (2.13 KB, patch)
2010-05-05 14:16 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 00:50:28 UTC


---- Reported by oleonard@myacpl.org 2008-07-21 06:33:47 ----

When opac-detail.pl displays a serial record, the template is told to display two additional columns in the "Holdings" table: "Serial Data," and "Published." Inside the ITEM_RESULTS loop:

<!-- TMPL_IF NAME="serial" --><td><!-- TMPL_VAR NAME="serialseq" --> </td>
<td><!-- TMPL_VAR NAME="publisheddate" --> </td><!-- /TMPL_IF -->

"serial" never evaluates as true even for serial records. The result is that the "status" data displays under "Serial Data" because the columns are shifted to the left. Even if you take out the check for "serial," "serialseq" and "publisheddate" do not display.

So, two problems:

1. Come up with a switch inside ITEM_RESULTS that will accurately check for a serial record.
2. Populate "serialseq" and "publisheddate" with the correct values.



---- Additional Comments From adrea@moablibrary.org 2009-03-11 17:19:21 ----

This might be separate bug, but it is definitely related to this bug.  The serial holdings columns - "Serial Data" and "Published" are showing up in inappropriate records in our OPAC details display.
Any records that are imported into our catalog which are part of a series have these empty columns in their details.

For example the book "Bloody Jack" 1st in the series "A Bloody Jack Adventure" has empty "Serial Data" and "Published" columns in its details page in our OPAC.

I will try to attach a Word doc with a screen shot, but I may or may not be successful. :)





---- Additional Comments From adrea@moablibrary.org 2009-03-11 17:20:55 ----

Created an attachment
Serial Columns Error Example





---- Additional Comments From oleonard@myacpl.org 2010-02-05 14:42:46 ----

Created an attachment
Screenshot of the problem

This bug still applies to HEAD, pre-3.2. In this example screenshot you see a monograph record which contains a 440a and a 440v. The presence of these tags triggers the display of columns only relevant to serials. Given that true serial records will have a "Subscriptions" tab to show "Serial Data," it looks like these columns should be removed altogether from the Holdings table.



---- Additional Comments From oleonard@myacpl.org 2010-02-05 14:44:02 ----

Created an attachment
Screenshot showing same record with 440 tag removed

This screenshot shows the same record with the 440 tag removed just to show that the 440 tag is what triggers the error.



---- Additional Comments From oleonard@myacpl.org 2010-02-05 15:14:07 ----

Created an attachment
Proposed fix

Removing markup to display serial data in the holdings table. This functionality (if it worked) would seem to duplicate the data displayed under the 'Subscriptions' tab



---- Additional Comments From oleonard@myacpl.org 2010-02-15 14:03:14 ----

*** http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4187 has been marked as a duplicate of this bug. ***



---- Additional Comments From oleonard@myacpl.org 2010-05-04 15:15:40 ----

Created an attachment
Revised fix (older patch no longer applied)





---- Additional Comments From oleonard@myacpl.org 2010-05-05 14:16:54 ----

Created an attachment
Revised fix (older patch no longer applied)

Another revision to merge changes to item status display



---- Additional Comments From gmcharlt@gmail.com 2010-05-05 15:14:38 ----

Patch pushed.  Please test and close.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 00:50 UTC  ---

This bug was previously known as _bug_ 2375 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2375
Imported an attachment (id=648)
Imported an attachment (id=649)
Imported an attachment (id=650)
Imported an attachment (id=651)
Imported an attachment (id=652)
Imported an attachment (id=653)

Actual time not defined. Setting to 0.0
CC member adrea@moablibrary.org does not have an account here
CC member bchurch@ptfs.com does not have an account here
CC member rch@liblime.com does not have an account here
The original submitter of attachment 648 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 649 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 650 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 651 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 652 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 653 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Owen Leonard 2010-06-04 16:29:24 UTC
*** Bug 3911 has been marked as a duplicate of this bug. ***