Bug 23960 - Issue with MariaDB version (rows column name in creator_template table)
Summary: Issue with MariaDB version (rows column name in creator_template table)
Status: RESOLVED DUPLICATE of bug 23289
Alias: None
Product: Koha
Classification: Unclassified
Component: Database (show other bugs)
Version: master
Hardware: All All
: P2 major (vote)
Assignee: Amit Gupta
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-04 09:09 UTC by Amit Gupta
Modified: 2019-11-08 11:59 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Amit Gupta 2019-11-04 09:09:04 UTC
Using 'rows' as a column name in creator_templates table giving error while saving.

(Issue with MariaDB version: 10.3.13).

As in MariaDB 'rows' is a predefined column name.

I think we can change the column name rows to rowls
Comment 1 Chris Cormack 2019-11-07 18:54:13 UTC
Switching to the DB component so we can try to gather all the DB changes together
Comment 2 Martin Renvoize 2019-11-08 11:07:59 UTC
Can you detail how to replicate this issue Amit.. having dug around the codebase it looks like 'rows' is always correctly quoted as an identifier to me, so I'm struggling to narrow down the problem.
Comment 3 Amit Gupta 2019-11-08 11:16:08 UTC
(In reply to Martin Renvoize from comment #2)
> Can you detail how to replicate this issue Amit.. having dug around the
> codebase it looks like 'rows' is always correctly quoted as an identifier to
> me, so I'm struggling to narrow down the problem.

Hi Martin,

I am using MariaDB version 10.3.13 (while saving the template I found the issue) and checked the log giving errors.

Seems "rows" are the keyword in MariaDB 10.3.13.

Can you install 10.3.13 and see the issue.
Comment 4 Jonathan Druart 2019-11-08 11:34:11 UTC
Amit, which version of Koha? Steps to recreate?

See also bug 23289, which is supposed to have fixed that.
Comment 5 Jonathan Druart 2019-11-08 11:34:58 UTC
(collision with Martin!)
Comment 6 Amit Gupta 2019-11-08 11:47:20 UTC
(In reply to Jonathan Druart from comment #4)
> Amit, which version of Koha? Steps to recreate?
> 
> See also bug 23289, which is supposed to have fixed that.

Thanks, Jonathan

I applied the patch and the issue is resolved. I am using 18.11
Comment 7 Jonathan Druart 2019-11-08 11:59:28 UTC

*** This bug has been marked as a duplicate of bug 23289 ***