Bug 24142 - Count of search results does not match displayed records with OpacHiddenItems
Summary: Count of search results does not match displayed records with OpacHiddenItems
Status: RESOLVED DUPLICATE of bug 17787
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-02 14:08 UTC by Rogan Hamby
Modified: 2019-12-07 10:23 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rogan Hamby 2019-12-02 14:08:04 UTC
My apologies if this is a duplicate but after searching I could not find it already in bugzilla.

When doing a standard search the search results count does not match the number of records shown if a record is hidden due to preferences.  

For example, I have 5 records that return with a keyword search of 'Hobbit'.  One has no items.  If I had an item to the item-less record with a CCODE set to be hidden with OpacHiddenItems the record is now correctly hidden but the search count continues to say "Your search returned 5 results."
Comment 1 Katrin Fischer 2019-12-07 10:23:32 UTC
Hi Rogan, found it: bug 17787

*** This bug has been marked as a duplicate of bug 17787 ***