Bug 2520 - when changing hold priorities, item-level holds can become bib-level holds
Summary: when changing hold priorities, item-level holds can become bib-level holds
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-14 08:20 UTC by Galen Charlton
Modified: 2012-10-25 21:28 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 00:52:07 UTC


---- Reported by gmcharlt@gmail.com 2008-08-14 08:20:06 ----

When editing the queue of hold requests for a bib (reserve/request.pl), changing the priority of any holds will cause all pending item-level requests to be bib-level requests because reserves.itemnumber is cleared.



---- Additional Comments From gmcharlt@gmail.com 2008-08-14 09:24:33 ----

*** http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2378 has been marked as a duplicate of this bug. ***



---- Additional Comments From gmcharlt@gmail.com 2008-08-18 06:26:07 ----

Nicole, please test and close - note that http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2378 was subsumed under this one.



---- Additional Comments From nengard@gmail.com 2008-08-19 11:30:11 ----

Works!!



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 00:52 UTC  ---

This bug was previously known as _bug_ 2520 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2520

Actual time not defined. Setting to 0.0