Bug 25686 - Title in the catalogue search result doesn't open the full (normal) record display
Summary: Title in the catalogue search result doesn't open the full (normal) record di...
Status: RESOLVED DUPLICATE of bug 19261
Alias: None
Product: Koha
Classification: Unclassified
Component: bugs.koha-community.org (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on: 23309 24458
Blocks:
  Show dependency treegraph
 
Reported: 2020-06-07 04:49 UTC by Iming Chan
Modified: 2020-07-23 04:07 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Screen shot (148.41 KB, image/jpeg)
2020-06-07 04:49 UTC, Iming Chan
Details
OPAC full catalogue record access error (272.98 KB, image/jpeg)
2020-06-07 11:54 UTC, Iming Chan
Details
MARC screenshot. (252.46 KB, image/jpeg)
2020-06-07 12:15 UTC, Iming Chan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Iming Chan 2020-06-07 04:49:45 UTC
Created attachment 105608 [details]
Screen shot

After you make a search and the search result appears.  Click on any title and you get an error message of "The record you requested does not exist ()".

Upon close inspection, I noticed that when you mouseover a title on the search result list, the biblionumber for that item is missing from the link URL.  For example:

https://koha.rosewoodfarm.com.au/cgi-bin/koha/catalogue/detail.pl?biblionumber=#####&searchid=scs_1591504570600

Once you entered a biblionumber, the normal catalogue record is showing.

So looks like biblionumber has dropped out for every catalogue record!  

I'm running Koha 19.11.06.000 and have never made any setting change.
Comment 1 Katrin Fischer 2020-06-07 10:42:58 UTC
Hi, I have tested in 19.11.06 and the links work ok for me from catalog and cataloguing search. Usually the error you see appears when your index is not up to date and you have records in the result list that have since been removed from Koha. Please try a full reindex.

I am lowering the severity for now.
Comment 2 Iming Chan 2020-06-07 11:52:58 UTC
After upgraded to 20.05 and fully reindex, the problem still exist.

However I just noticed that in the staff client, on the search result list, if you click on the image column (whether there is a cover image or not), it will take you to the normal display (full catalogue record).

Whereas, if you click on the title hyperlink, the "biblionumber" is missing and thus cannot get to the normal (full record display).

In the OPAC, click on the cover image will take you to the full catalogue record.  However, when there is no cover image ("No cover image" hidden), then you cannot get into the full catalogue record.  You get an error message (see screenshot attached).

Does this have anything to do with Bug # 24740 (implemented recently)?
Comment 3 Iming Chan 2020-06-07 11:54:06 UTC
Created attachment 105611 [details]
OPAC full catalogue record access error
Comment 4 Katrin Fischer 2020-06-07 11:58:17 UTC
Which MARC format are you using?
Have you chanced the XSLT files in any way?

I believe this could also happen if your biblionumber is not stored in the expected MARC field. For MARC21 this would be 999.
Comment 5 Iming Chan 2020-06-07 12:15:08 UTC
We are using Marc21 and the default XSLT is used (admin preference never changed).

We have always used 999 $c and $d for biblionumber (even though, we also copy the exact same number to 001).

See screenshot attached.
Comment 6 Iming Chan 2020-06-07 12:15:43 UTC
Created attachment 105615 [details]
MARC screenshot.
Comment 7 Katrin Fischer 2020-06-07 12:18:51 UTC
Sorry, not sure what's going on then. I can't replicate the bug on a fresh 19.11 installation.
Comment 8 Iming Chan 2020-06-07 12:21:03 UTC
I suspect this problem only occurred after we upgraded to 19.11.06 as it was working fine last week.
Comment 9 Jonathan Druart 2020-06-08 08:21:04 UTC
What do you have in OPACXSLTResultsDisplay? Did you modify the default XSLT?
Comment 10 Jonathan Druart 2020-06-08 08:30:27 UTC
Also, try to restart memcached, then koha-common.
Comment 11 Iming Chan 2020-06-08 08:36:34 UTC
We have made no change to any of our setting.  Our IT person has setup an auto upgrade of Koha when available and we got 19.11.06 recently.  To attempt to fix this problem, we have upgraded to 20.05 since without luck.

It seems that you have to click on the cover image instead of title to open the full catalogue (normal display).  This causes a major problem in our OPAC as not all items have cover image.
Comment 12 Iming Chan 2020-06-08 08:39:19 UTC
I'm suspecting this behaviour may have something to do with Bug # 24740.
Comment 13 Jonathan Druart 2020-06-08 09:02:38 UTC
I don't think it's related with bug 24740.

Please confirm the value in the syspref and that you correctly restart the different services.

The problem you have is that the variable "biblionumber" is not correctly picked for the XSLT processing.

I also see different uncommon things in your catalogue:
 - https://snipboard.io/scgRqV.jpg
 - you have itemtypes with '*', like '*_LB', is that correct? Did you create it recently?
Comment 14 David Cook 2020-06-09 00:08:55 UTC
The issue was due to Bug 24458. 

Iming's bibliographic frameworks are quite old I think, so they didn't have the OPAC and Intranet checkboxes ticked for the 999$c in the Default framework.

While a fresh database will have the latest MARC bibliographic framework, upgraded databases never get updated MARC bibliographic framework data.

This is an issue I've been pondering for years. Personally, I'd love to see the "Default Framework" be managed by Koha rather than by end users, so that we could constantly update it with the latest and greatest configuration.
Comment 15 Katrin Fischer 2020-06-11 19:30:34 UTC
> This is an issue I've been pondering for years. Personally, I'd love to see
> the "Default Framework" be managed by Koha rather than by end users, so that
> we could constantly update it with the latest and greatest configuration.

I am not sure about this, we'd need to allow local changes. For example we have several custom fields agreed on for data exchange in Germany and in between libraries in certain areas.
Comment 16 David Cook 2020-06-12 04:48:32 UTC
(In reply to Katrin Fischer from comment #15)
> > This is an issue I've been pondering for years. Personally, I'd love to see
> > the "Default Framework" be managed by Koha rather than by end users, so that
> > we could constantly update it with the latest and greatest configuration.
> 
> I am not sure about this, we'd need to allow local changes. For example we
> have several custom fields agreed on for data exchange in Germany and in
> between libraries in certain areas.

Hmm that's a good point. 

Maybe we should have a "Reference" MARC Bibliographic Framework that is not the "Default", but which gets updated during upgrades. 

Maybe we could have a "diff tool" for showing the differences between "Reference" and any other framework, and have a user-friendly method for updating other frameworks from the "Reference" framework. 

The onus would still be on Koha users to update their frameworks, but at least they'd have the ability to do it in a practical (and authoritative) way.
Comment 17 Katrin Fischer 2020-06-22 21:27:46 UTC
*** Bug 25826 has been marked as a duplicate of this bug. ***
Comment 18 Katrin Fischer 2020-06-22 21:29:28 UTC
I think we should make sure that the biblionumber cannot be hidden in the frameworks or at least output a warning on the system information tab if the field linked to biblionumber is set to hidden in OPAC.
Comment 19 David Cook 2020-06-23 01:41:52 UTC
(In reply to Katrin Fischer from comment #18)
> I think we should make sure that the biblionumber cannot be hidden in the
> frameworks or at least output a warning on the system information tab if the
> field linked to biblionumber is set to hidden in OPAC.

Agreed
Comment 20 David Cook 2020-07-23 03:49:10 UTC

*** This bug has been marked as a duplicate of bug 19261 ***
Comment 21 David Cook 2020-07-23 03:59:38 UTC

*** This bug has been marked as a duplicate of bug 19261 ***
Comment 22 David Cook 2020-07-23 04:07:52 UTC
Ok I just reproduced this in master on koha-testing-docker after hiding 999$c in Default and Books* frameworks, and then doing this staff interface search:

local-number:29 or local-number:30

It created search results with the following links:

http://localhost:8081/cgi-bin/koha/catalogue/detail.pl?biblionumber=&searchid=scs_1595477248050

http://localhost:8081/cgi-bin/koha/catalogue/detail.pl?biblionumber=&searchid=scs_1595477248050

As you can see, the biblionumber is missing.