Bug 25775 - Add DataTables controls to user's checkouts table in OPAC
Summary: Add DataTables controls to user's checkouts table in OPAC
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords: Manual
: 26570 (view as bug list)
Depends on: 20168 26262
Blocks:
  Show dependency treegraph
 
Reported: 2020-06-16 15:45 UTC by Owen Leonard
Modified: 2021-08-26 14:42 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
This patch adds some tools to the display of checkouts, overdues, holds, etc. in the logged-in user's view of their account in the OPAC. Users logged in using a JavaScript-capable browser will now see a filter form for instantly searching the contents of these tables. Controls will be shown to copy the data in the table, export the contents as a CSV file, or print a print-friendly version of the data in the table.
Version(s) released in:
21.05.00


Attachments
Screenshot of the revised interface (349.22 KB, image/png)
2020-06-16 16:23 UTC, Owen Leonard
Details
Bug 25775: Add DataTables controls to user's checkouts table in OPAC (37.71 KB, patch)
2020-11-09 17:28 UTC, Owen Leonard
Details | Diff | Splinter Review
Updated screenshot (55.04 KB, image/png)
2020-11-09 17:29 UTC, Owen Leonard
Details
Bug 25775: Add DataTables controls to user's checkouts table in OPAC (37.77 KB, patch)
2020-12-03 16:24 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 25775: Add DataTables controls to user's checkouts table in OPAC (37.77 KB, patch)
2021-01-10 22:20 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 25775: Add DataTables controls to user's checkouts table in OPAC (37.77 KB, patch)
2021-01-10 22:21 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 25775: Add DataTables controls to user's checkouts table in OPAC (37.78 KB, patch)
2021-01-12 15:13 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2020-06-16 15:45:00 UTC
It would be helpful for the user to have some DataTables controls on their table of checked-out items (and perhaps other tables on that page as well):

 - Filter form
 - Copy
 - CSV
 - Print
Comment 1 Owen Leonard 2020-06-16 16:23:56 UTC
Created attachment 105928 [details]
Screenshot of the revised interface

I think including the renew and ical controls makes sense if we're adding buttons
Comment 2 Katrin Fischer 2020-06-22 22:56:24 UTC
Looks really nice and I like the new placement of the ical link.
Comment 3 Owen Leonard 2020-11-09 17:28:05 UTC
Created attachment 113331 [details] [review]
Bug 25775: Add DataTables controls to user's checkouts table in OPAC

This patch updates the "your summary" page in the OPAC so that tables on
the logged-in user's page have DataTables controls. The patch also
tweaks the DataTable configuration of some other pages to make them all
more consistent.

To test, apply the patch and rebuild the OPAC CSS
(https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client).

- Log in to the OPAC as a user who has checkouts, overdues, and holds.
- On the "your summary" page, confirm that the checkouts table has
  controls at the top: A search form and link-style buttons: Clear
  filter, Copy, CSV, Print, iCal, Renew selected, and Renew all.
- Confirm that each work correctly.
- At the bottom of the page, the style of the "Renew selected" and
  "Renew all" buttons should now be side by side.
- Confirm that both buttons work correctly.
- If necessary, enable the UseCourseReserves system preference.
- Go to the OPAC course reserves page.
- Confirm that there is a working "Search courses" field at the top of
  the table.
- View the contents of a course reserve.
- There should be a "Search course reserves" field at the top of the
  table.
Comment 4 Owen Leonard 2020-11-09 17:29:08 UTC
Created attachment 113332 [details]
Updated screenshot
Comment 5 Lucas Gass 2020-12-03 16:24:08 UTC
Created attachment 114153 [details] [review]
Bug 25775: Add DataTables controls to user's checkouts table in OPAC

This patch updates the "your summary" page in the OPAC so that tables on
the logged-in user's page have DataTables controls. The patch also
tweaks the DataTable configuration of some other pages to make them all
more consistent.

To test, apply the patch and rebuild the OPAC CSS
(https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client).

- Log in to the OPAC as a user who has checkouts, overdues, and holds.
- On the "your summary" page, confirm that the checkouts table has
  controls at the top: A search form and link-style buttons: Clear
  filter, Copy, CSV, Print, iCal, Renew selected, and Renew all.
- Confirm that each work correctly.
- At the bottom of the page, the style of the "Renew selected" and
  "Renew all" buttons should now be side by side.
- Confirm that both buttons work correctly.
- If necessary, enable the UseCourseReserves system preference.
- Go to the OPAC course reserves page.
- Confirm that there is a working "Search courses" field at the top of
  the table.
- View the contents of a course reserve.
- There should be a "Search course reserves" field at the top of the
  table.

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>
Comment 6 Lucas Gass 2020-12-03 16:24:59 UTC
This new look is very nice and each of the new controls works well!
Comment 7 Katrin Fischer 2021-01-10 22:20:59 UTC
Created attachment 114998 [details] [review]
Bug 25775: Add DataTables controls to user's checkouts table in OPAC

This patch updates the "your summary" page in the OPAC so that tables on
the logged-in user's page have DataTables controls. The patch also
tweaks the DataTable configuration of some other pages to make them all
more consistent.

To test, apply the patch and rebuild the OPAC CSS
(https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client).

- Log in to the OPAC as a user who has checkouts, overdues, and holds.
- On the "your summary" page, confirm that the checkouts table has
  controls at the top: A search form and link-style buttons: Clear
  filter, Copy, CSV, Print, iCal, Renew selected, and Renew all.
- Confirm that each work correctly.
- At the bottom of the page, the style of the "Renew selected" and
  "Renew all" buttons should now be side by side.
- Confirm that both buttons work correctly.
- If necessary, enable the UseCourseReserves system preference.
- Go to the OPAC course reserves page.
- Confirm that there is a working "Search courses" field at the top of
  the table.
- View the contents of a course reserve.
- There should be a "Search course reserves" field at the top of the
  table.

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>
Comment 8 Katrin Fischer 2021-01-10 22:21:58 UTC
Created attachment 114999 [details] [review]
Bug 25775: Add DataTables controls to user's checkouts table in OPAC

This patch updates the "your summary" page in the OPAC so that tables on
the logged-in user's page have DataTables controls. The patch also
tweaks the DataTable configuration of some other pages to make them all
more consistent.

To test, apply the patch and rebuild the OPAC CSS
(https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client).

- Log in to the OPAC as a user who has checkouts, overdues, and holds.
- On the "your summary" page, confirm that the checkouts table has
  controls at the top: A search form and link-style buttons: Clear
  filter, Copy, CSV, Print, iCal, Renew selected, and Renew all.
- Confirm that each work correctly.
- At the bottom of the page, the style of the "Renew selected" and
  "Renew all" buttons should now be side by side.
- Confirm that both buttons work correctly.
- If necessary, enable the UseCourseReserves system preference.
- Go to the OPAC course reserves page.
- Confirm that there is a working "Search courses" field at the top of
  the table.
- View the contents of a course reserve.
- There should be a "Search course reserves" field at the top of the
  table.

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>
Comment 9 Jonathan Druart 2021-01-12 15:13:11 UTC
Created attachment 115094 [details] [review]
Bug 25775: Add DataTables controls to user's checkouts table in OPAC

This patch updates the "your summary" page in the OPAC so that tables on
the logged-in user's page have DataTables controls. The patch also
tweaks the DataTable configuration of some other pages to make them all
more consistent.

To test, apply the patch and rebuild the OPAC CSS
(https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client).

- Log in to the OPAC as a user who has checkouts, overdues, and holds.
- On the "your summary" page, confirm that the checkouts table has
  controls at the top: A search form and link-style buttons: Clear
  filter, Copy, CSV, Print, iCal, Renew selected, and Renew all.
- Confirm that each work correctly.
- At the bottom of the page, the style of the "Renew selected" and
  "Renew all" buttons should now be side by side.
- Confirm that both buttons work correctly.
- If necessary, enable the UseCourseReserves system preference.
- Go to the OPAC course reserves page.
- Confirm that there is a working "Search courses" field at the top of
  the table.
- View the contents of a course reserve.
- There should be a "Search course reserves" field at the top of the
  table.

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 10 Jonathan Druart 2021-01-12 15:13:23 UTC
Added missing Signed-off-by line from QA.
Comment 11 Jonathan Druart 2021-01-14 13:04:36 UTC
Pushed to master for 21.05, thanks to everybody involved!
Comment 12 Fridolin Somers 2021-01-18 15:07:50 UTC
Enhancement not pushed to 20.11.x
Comment 13 Jonathan Druart 2021-02-09 11:06:27 UTC
Owen, please fill the release notes.
Comment 14 Jonathan Druart 2021-08-26 14:42:32 UTC
*** Bug 26570 has been marked as a duplicate of this bug. ***