Bug 25803 - Internet Explorer: unable to save patron edits or view patron checkouts
Summary: Internet Explorer: unable to save patron edits or view patron checkouts
Status: CLOSED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: Browser compatibility (show other bugs)
Version: 19.11
Hardware: All All
: P5 - low major (vote)
Assignee: David Cook
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-18 11:20 UTC by Janet McGowan
Modified: 2021-06-14 21:29 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janet McGowan 2020-06-18 11:20:54 UTC
This is on the staff interface.
On 19.11 sites using Internet Explorer 11 we have found 2 issues:

- /members/memberentry.pl make an edit to a patron record and click Save. The page does not save.

- If a user has checkouts, on /members/moremember.pl in the issues table no issues are displayed. Click on Always show checkouts immediately and no issues are displayed.

I marked this as Major as we still have customers with organisations restricted to using IE. 

Thanks.
Comment 1 Owen Leonard 2020-06-18 18:06:28 UTC
For what it's worth this problem doesn't seem to affect Microsoft's new Chromium-based version, Version 83.0.x, which my Windows computer installed without asking me.
Comment 2 Owen Leonard 2020-06-18 19:15:36 UTC
(In reply to Janet McGowan from comment #0)
> This is on the staff interface.
> On 19.11 sites using Internet Explorer 11 we have found 2 issues:
> 
> - /members/memberentry.pl make an edit to a patron record and click Save.
> The page does not save.

This is cause by a JavaScript error stemming from a change to members.js in Bug 14570 - Make it possible to add multiple guarantors to a record. Line 169 of the file introduces the use of template literals (https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Template_literals) which are unsupported in Internet Explorer 11 and before.

I'm inclined not to make accommodations for a browser which is so old. Internet Explorer 11 was first released in 2013. Since then two newer Microsoft browsers have been released: Edge in 2015, updated in 2019 to the Chromium-based version.

The latest version of Edge is available for Windows 7, 8, and 10.



> - If a user has checkouts, on /members/moremember.pl in the issues table no
> issues are displayed. Click on Always show checkouts immediately and no
> issues are displayed.

I could not reproduce this problem even in IE11.
Comment 3 Katrin Fischer 2020-06-22 22:52:17 UTC
Iirc we are not officially supporting IE for the staff interface, but only for the browser. But could only locate a note in the manual: 
https://koha-community.org/manual/20.05/en/html/intro.html?highlight=explorer

Is support of browser versions something we should discuss at the next meeting?
Comment 4 David Cook 2020-06-23 01:52:22 UTC
I'll be fixing this (sooner or later) locally, since we have many clients that use IE 11. (Many of these clients having their browser usage forced on them by corporate IT policies.)

I'll submit my patches here whether or not the community chooses to accept them.

Maybe we should default me as the Assignee for the "Browser compatibility" component, as I'm going to be supporting IE for as long as I work at Prosentient Systems.
Comment 5 David Cook 2020-06-30 07:23:43 UTC
Admittedly despite me saying that I'd look at fixing it, I haven't had the time, and based on the info from Owen, it might not be trivial to do such a fix.
Comment 6 David Cook 2020-07-01 05:40:16 UTC
Ok looking at this again...

Using https://babeljs.io/, it's suggesting the following.

Replace:
$(`.guarantor-details[data-borrowernumber=${borrower.borrowernumber}]`).length;

With:
(".guarantor-details[data-borrowernumber=".concat(borrower.borrowernumber, "]")).length;

However, I notice ./koha-tmpl/opac-tmpl/lib/kjua/lib/dom.js uses template literals as well, and there might be other Javascript that does too. 

As Owen said, really there's no reason people should be using computers without Edge, and Edge supports newer Javascript, so I think the best solution might actually be to push back on Intranet users and advise that the Koha Intranet isn't fully compatible with older browsers like IE 11.
Comment 7 David Cook 2020-09-02 04:31:58 UTC
I get support calls about this on a weekly basis, so I'm going to apply Bug 26305 locally, so that staff users get a warning that IE 11 won't work for them.