Bug 25839 - Typo patron.streetype in member-main-address-style.inc
Summary: Typo patron.streetype in member-main-address-style.inc
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Fridolin Somers
QA Contact: Testopia
URL:
Keywords:
Depends on: 25070
Blocks: 25842
  Show dependency treegraph
 
Reported: 2020-06-22 09:35 UTC by Fridolin Somers
Modified: 2020-11-30 21:52 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:
20.11.00 20.05.01


Attachments
Bug 25839: Fix typo patron.streetype in member-main-address-style.inc (1.51 KB, patch)
2020-06-22 09:58 UTC, Fridolin Somers
Details | Diff | Splinter Review
Bug 25839: Fix typo patron.streetype in member-main-address-style.inc (1.57 KB, patch)
2020-06-22 12:54 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 25839: Fix typo patron.streetype in member-main-address-style.inc (1.63 KB, patch)
2020-06-22 21:03 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin Somers 2020-06-22 09:35:21 UTC
Typo in member-main-address-style.inc : patron.streetype > patron.streettype

Generates error :
Template process failed: undef error - The method Koha::Patron->streetype is not covered by tests!
Comment 1 Fridolin Somers 2020-06-22 09:58:38 UTC
Created attachment 106156 [details] [review]
Bug 25839: Fix typo patron.streetype in member-main-address-style.inc

Typo in member-main-address-style.inc : patron.streetype > patron.streettype

Generates error :
Template process failed: undef error - The method Koha::Patron->streetype is not covered by tests!

Test plan : try create a new patron
Comment 2 Owen Leonard 2020-06-22 12:54:52 UTC
Created attachment 106165 [details] [review]
Bug 25839: Fix typo patron.streetype in member-main-address-style.inc

Typo in member-main-address-style.inc : patron.streetype > patron.streettype

Generates error :
Template process failed: undef error - The method Koha::Patron->streetype is not covered by tests!

Test plan : try create a new patron

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 3 Owen Leonard 2020-06-22 12:55:56 UTC
I couldn't reproduce the error in my tests, but the fix look correct so I signed off.
Comment 4 Katrin Fischer 2020-06-22 21:03:58 UTC
Created attachment 106169 [details] [review]
Bug 25839: Fix typo patron.streetype in member-main-address-style.inc

Typo in member-main-address-style.inc : patron.streetype > patron.streettype

Generates error :
Template process failed: undef error - The method Koha::Patron->streetype is not covered by tests!

Test plan : try create a new patron

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Jonathan Druart 2020-06-23 08:30:03 UTC
Pushed to master for 20.11, thanks to everybody involved!
Comment 6 Jonathan Druart 2020-06-23 08:41:08 UTC
backported to 20.05.x for 20.05.01
Comment 7 Aleisha Amohia 2020-06-24 00:28:59 UTC
missing dependencies, not backported to 19.11.x