Bug 25920 - Add liblocale-codes-perl package to fix ubuntu-stable (focal)
Summary: Add liblocale-codes-perl package to fix ubuntu-stable (focal)
Status: Pushed to oldstable
Alias: None
Product: Koha
Classification: Unclassified
Component: Packaging (show other bugs)
Version: master
Hardware: All All
: P1 - high blocker (vote)
Assignee: Mason James
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-03 11:26 UTC by Mason James
Modified: 2020-09-19 01:42 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
20.11.00, 20.05.03, 19.11.09


Attachments
Bug 25920: Add liblocale-codes-perl package to fix ubuntu-stable (focal) (2.47 KB, patch)
2020-07-03 11:55 UTC, Mason James
Details | Diff | Splinter Review
Bug 25920: Add liblocale-codes-perl package to fix ubuntu-stable (focal) (2.61 KB, patch)
2020-07-03 11:58 UTC, Mason James
Details | Diff | Splinter Review
pic of error (295.20 KB, image/png)
2020-07-09 01:33 UTC, Mason James
Details
Bug 25920: Add liblocale-codes-perl package to fix ubuntu-stable (focal) (2.64 KB, patch)
2020-07-22 07:49 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 25920: Add liblocale-codes-perl package to fix ubuntu-stable (focal) (2.79 KB, patch)
2020-07-29 10:20 UTC, Joonas Kylmälä
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mason James 2020-07-03 11:26:35 UTC
This bug tracks the task of adding the liblocale-codes-perl package, to fix ubuntu-stable (focal)

looks like perl-5.30 on debian needs liblocale-codes-perl

root@buster:kohadevbox$ pmvers  Locale::Language
Locale::Language will be removed from the Perl core distribution in the next major release. Please install the separate liblocale-codes-perl package. It is being used at (eval 1), line 1.

Locale::Codes will be removed from the Perl core distribution in the next major release. Please install the separate liblocale-codes-perl package. It is being used at /usr/share/perl/5.28/Locale/Language.pm, line 22.
3.56
Comment 2 Mason James 2020-07-03 11:58:30 UTC
Created attachment 106497 [details] [review]
Bug 25920: Add liblocale-codes-perl package to fix ubuntu-stable (focal)

to test on ubuntu-20...

1/ install koha-common pkg
 $ sudo apt install koha-common

2/ confirm liblocale-codes-perl pkg is not installed :(
 $ apt-cache policy  liblocale-codes-perl | grep Installed
 Installed: (none)

3/ apply patch

4/ build and install new koha-common pkg

5/ confirm liblocale-codes-perl pkg is now installed :)
 $ apt-cache policy  liblocale-codes-perl | grep Installed
 Installed: 3.62-1
Comment 3 Mason James 2020-07-09 01:08:20 UTC
> 5/ confirm liblocale-codes-perl pkg is now installed :)
>  $ apt-cache policy  liblocale-codes-perl | grep Installed
>  Installed: 3.62-1


until this patch is pushed, you can manually fix this problem with the following command

$ sudo apt install liblocale-codes-perl
Comment 4 Mason James 2020-07-09 01:33:25 UTC
Created attachment 106672 [details]
pic of error
Comment 5 Mason James 2020-07-09 01:38:44 UTC
(In reply to Mason James from comment #0)
> This bug tracks the task of adding the liblocale-codes-perl package, to fix
> ubuntu-stable (focal)
> 
> looks like perl-5.30 on debian needs liblocale-codes-perl


hmm, problem exists on debian 11 too
Comment 6 Mason James 2020-07-09 23:03:13 UTC
(In reply to Mason James from comment #5)
> (In reply to Mason James from comment #0)
> > This bug tracks the task of adding the liblocale-codes-perl package, to fix
> > ubuntu-stable (focal)
> > 
> > looks like perl-5.30 on debian needs liblocale-codes-perl
> 
> 
> hmm, problem exists on debian 11 too

this seems to stop installation at the 'web installer' stage
Comment 7 Martin Renvoize 2020-07-22 07:49:21 UTC
Created attachment 107171 [details] [review]
Bug 25920: Add liblocale-codes-perl package to fix ubuntu-stable (focal)

to test on ubuntu-20...

1/ install koha-common pkg
 $ sudo apt install koha-common

2/ confirm liblocale-codes-perl pkg is not installed :(
 $ apt-cache policy  liblocale-codes-perl | grep Installed
 Installed: (none)

3/ apply patch

4/ build and install new koha-common pkg

5/ confirm liblocale-codes-perl pkg is now installed :)
 $ apt-cache policy  liblocale-codes-perl | grep Installed
 Installed: 3.62-1

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 8 Martin Renvoize 2020-07-22 07:49:45 UTC
Works as expected from the test plan.  Signing off
Comment 9 Joonas Kylmälä 2020-07-29 10:20:14 UTC
Created attachment 107480 [details] [review]
Bug 25920: Add liblocale-codes-perl package to fix ubuntu-stable (focal)

to test on ubuntu-20...

1/ install koha-common pkg
 $ sudo apt install koha-common

2/ confirm liblocale-codes-perl pkg is not installed :(
 $ apt-cache policy  liblocale-codes-perl | grep Installed
 Installed: (none)

3/ apply patch

4/ build and install new koha-common pkg

5/ confirm liblocale-codes-perl pkg is now installed :)
 $ apt-cache policy  liblocale-codes-perl | grep Installed
 Installed: 3.62-1

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Signed-off-by: Joonas Kylmälä <joonas.kylmala@helsinki.fi>
Comment 10 Jonathan Druart 2020-07-30 15:47:06 UTC
Pushed to master for 20.11, thanks to everybody involved!
Comment 11 Lucas Gass 2020-08-06 19:59:46 UTC
backported to 20.05.x for 20.05.03
Comment 12 Aleisha Amohia 2020-08-07 01:43:02 UTC
backported to 19.11.x for 19.11.09
Comment 13 Victor Grousset/tuxayo 2020-09-19 01:42:57 UTC
Tried to backport to 19.05.x, got this conflict:

<<<<<<< HEAD
||||||| parent of f19e6015b0... Bug 25920: Add liblocale-codes-perl package to fix ubuntu-stable (focal)
    'CPAN::Meta'           => 'libcpan-meta-perl (>= 2.150010) | perl-modules-5.28 | perl-modules-5.30 | perl-modules (>= 5.20.2)'
=======
    'CPAN::Meta'           => 'libcpan-meta-perl (>= 2.150010) | perl-modules-5.28 | perl-modules-5.30 | perl-modules (>= 5.20.2)',
    'Locale::Language'     => 'liblocale-codes-perl'
>>>>>>> f19e6015b0... Bug 25920: Add liblocale-codes-perl package to fix ubuntu-stable (focal)


Aside from that, is that needed for 19.05.x? (recommended systems: Debian 9 & Ubuntu 18.04)