Bug 2614 - Facets in Alpha Order
Summary: Facets in Alpha Order
Status: CLOSED DUPLICATE of bug 4891
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: PC All
: P3 enhancement (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-16 11:27 UTC by Nicole C. Engard
Modified: 2012-10-26 00:41 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
facets (67.58 KB, image/png)
2008-09-16 11:27 UTC, Chris Cormack
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 00:53:29 UTC


---- Reported by nengard@gmail.com 2008-09-16 11:27:25 ----

Facets should be alphabetical - right now they appear random.  If they can't be sorted alphabetically can they have a number  hits in parens next to them - ex. (12) so that the order appears to make sense?



---- Additional Comments From nengard@gmail.com 2008-09-16 11:27:43 ----

Created an attachment
facets





---- Additional Comments From oleonard@myacpl.org 2008-09-16 11:39:05 ----

Facets used to show a count, but at the time the counts were accurate only with regard to the results on the screen, not the whole result set. If I recall correctly, getting a count for the whole result set was an issue.



---- Additional Comments From nengard@gmail.com 2008-09-16 11:43:27 ----

Okay - then alpha order - right now it's hard to find the author you're looking for an the librarians are confused as to what the order is.



---- Additional Comments From jwagner@ptfs.com 2009-09-04 13:29:57 ----

Updating this after discussion on the IRC today.  It seems that the contents of each facet category (Author, Topic, whatever) display in order of frequency from the entire hitlist -- the most frequently used subject will be first.  However, the count display (which is presently turned off) only applies to the _current page_ of the results list, which is misleading and fairly useless.

I think that maybe a couple of things are needed here.  Either fix the count so that it displays and applies to the whole results list, or give the site the ability to sort the contents of each facet alphabetically (so that users can find what they may be looking for more easily), or at least note on the screen that the lists are in order by most heavily used first.





---- Additional Comments From paul.poulain@biblibre.com 2009-09-04 15:13:56 ----

unless i'm missing something :
- the facets are calculated by Koha. Calculating them on all the result set would result in very very poor performances. Thus, the calculation on the screen part only.
- zebra now contains some features to build facets, but no one ever took time to use them in koha afaik




--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 00:53 UTC  ---

This bug was previously known as _bug_ 2614 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2614
Imported an attachment (id=759)

Actual time not defined. Setting to 0.0
CC member bchurch@ptfs.com does not have an account here
CC member jwagner@ptfs.com does not have an account here
The original submitter of attachment 759 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Nicole C. Engard 2010-06-15 12:48:54 UTC

*** This bug has been marked as a duplicate of bug 4891 ***