Bug 26192 - Elasticsearch does not sort call numbers correctly
Summary: Elasticsearch does not sort call numbers correctly
Status: RESOLVED DUPLICATE of bug 26051
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching - Elasticsearch (show other bugs)
Version: master
Hardware: All All
: P5 - low normal with 10 votes (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-11 14:31 UTC by Donna
Modified: 2021-01-29 20:22 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Donna 2020-08-11 14:31:08 UTC
Using LC classification and Elasticsearch results in call numbers not being sorted correctly.  For example, a search for call number VA65, with results sorted by call number 0-9 gives you this:
VA65 E7
VA65 E45
VA65 E57
VA65 E471

but in Zebra gives you the correct sort:
VA65 E45
VA65 E471
VA65 E57
VA65 E7
Comment 1 Heather 2020-08-11 14:57:24 UTC
This is a big problem for us impacting everything from new cataloging (can't shelflist accurately if one can't sort the call numbers accurately) to paging (sure slows paging down when the list isn't sorted correctly) to users doing virtual browsing of the shelves...

To see it live in our catalog with that VA65 call number range sorting the cutters as if they were whole numbers instead of decimals:
https://keys.bywatersolutions.com/cgi-bin/koha/opac-search.pl?q=callnum%2Cphr%3Ava65&offset=80&sort_by=call_number_asc

Thank you for anything anyone does to provide a fix!!!

Cheerio,
h2
Comment 2 Nick Clemens 2021-01-29 20:22:54 UTC

*** This bug has been marked as a duplicate of bug 26051 ***