Bug 26375 - SIP checkout message does not renew item
Summary: SIP checkout message does not renew item
Status: RESOLVED DUPLICATE of bug 25808
Alias: None
Product: Koha
Classification: Unclassified
Component: SIP2 (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-03 18:32 UTC by Andrew Fuerste-Henry
Modified: 2021-01-14 14:42 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Fuerste-Henry 2020-09-03 18:32:52 UTC
To recreate:
- Find or create a checked out item with 1 or more available renewals
- Via SIP CLI, send a checkout message for the same patron and item
- Receive error "Item checked out to another patron"

This should result in a renewal, if one is available.
Comment 1 Jonathan Druart 2020-12-01 10:08:03 UTC
Is it a regression?
Comment 2 Martin Renvoize 2021-01-14 14:42:32 UTC

*** This bug has been marked as a duplicate of bug 25808 ***