Bug 26387 - Suppress Holds Queue warning if hold is bib level and has an itemtype set
Summary: Suppress Holds Queue warning if hold is bib level and has an itemtype set
Status: RESOLVED DUPLICATE of bug 26367
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-04 12:28 UTC by Kyle M Hall
Modified: 2021-01-17 07:33 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 26387: Suppress Holds Queue warning if hold is bib level and has an itemtype set (1.59 KB, patch)
2020-09-04 12:30 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2020-09-04 12:28:16 UTC
If a hold is record level with an itemtype selected, a warning will be generated by the holds queue builder because $request->{itemnumber} }->{itype}.
Comment 1 Kyle M Hall 2020-09-04 12:30:36 UTC
Created attachment 109655 [details] [review]
Bug 26387: Suppress Holds Queue warning if hold is bib level and has an itemtype set

If a hold is record level with an itemtype selected, a warning will be generated by the holds queue builder because $request->{itemnumber} }->{itype}.

Test Plan:
1) Enable choosing of itemtype for holds
2) Place a bib level holds with an itemtype selected
3) Run holds queue builder
4) Note the warning
5) Apply this patch
6) Run the holds queue builder again
7) No warning!
Comment 2 Didier Gautheron 2021-01-17 07:33:27 UTC
Fixed in  #26367

*** This bug has been marked as a duplicate of bug 26367 ***