Bug 26544 - Make housebound module show delivery preferences when scheduling
Summary: Make housebound module show delivery preferences when scheduling
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Lucas Gass
QA Contact: Testopia
URL:
Keywords:
Depends on: 28810
Blocks:
  Show dependency treegraph
 
Reported: 2020-09-25 21:10 UTC by Donna
Modified: 2021-10-21 14:51 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:
21.11.00


Attachments
Bug 26544: Add housebound details to delivery page (5.45 KB, patch)
2021-07-29 22:47 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 26544: Add housebound details to delivery page (5.52 KB, patch)
2021-07-30 14:56 UTC, Andrew Fuerste-Henry
Details | Diff | Splinter Review
Bug 26544: Add housebound details to delivery page (5.98 KB, patch)
2021-09-02 17:06 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 26544: Add housebound details to delivery page (6.04 KB, patch)
2021-09-26 12:34 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Donna 2020-09-25 21:10:57 UTC
In the housebound module, you set the day and frequency in the details section, but when you schedule a new delivery, you cannot see the day or frequency, so users have no way of seeing when a delivery should be scheduled.  It would be helpful to see the day and frequency on the Delivery details section.
Comment 1 Andrew Fuerste-Henry 2021-07-29 15:52:36 UTC
+1, why would we collect this data but not make it visible in the screen where it matters?
Comment 2 Lucas Gass 2021-07-29 22:47:20 UTC
Created attachment 123290 [details] [review]
Bug 26544: Add housebound details to delivery page

To test:
1. Turn on the housebound module
2. go to the housebound for a given patron /cgi-bin/koha/members/housebound.pl?borrowernumber=X
3. add some housebound details, fill out all the fields
4. Go to 'Add a new delivery'
5. No housebound details, hard to know what the patron likes or days to deliver!
6. apply patch
7. Go to 'Add a delivery'
8. See the housebound details. yay!
Comment 3 Andrew Fuerste-Henry 2021-07-30 14:56:48 UTC
Created attachment 123334 [details] [review]
Bug 26544: Add housebound details to delivery page

To test:
1. Turn on the housebound module
2. go to the housebound for a given patron /cgi-bin/koha/members/housebound.pl?borrowernumber=X
3. add some housebound details, fill out all the fields
4. Go to 'Add a new delivery'
5. No housebound details, hard to know what the patron likes or days to deliver!
6. apply patch
7. Go to 'Add a delivery'
8. See the housebound details. yay!

Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com>
Comment 4 Katrin Fischer 2021-08-29 12:05:00 UTC
Looking at bug 28810 just before: do we not want to preserve the new lines here as well? 

Also it might be nice to add some IDs to the <li> to help people hide some information if it turns out a little much (not blocker, just suggesting)
Comment 5 Katrin Fischer 2021-08-29 12:08:22 UTC
Realizing this puts repeated mark-up in a BLOCK (excellent) which is probably the reason it currently conflicts with bug 28810. I think as 28810 is already PQA it would be good to make this apply cleanly on top - also helping to avoid regressions like the line breaks.
Comment 6 Lucas Gass 2021-09-02 17:06:15 UTC
Created attachment 124432 [details] [review]
Bug 26544: Add housebound details to delivery page

To test:
1. Turn on the housebound module
2. go to the housebound for a given patron /cgi-bin/koha/members/housebound.pl?borrowernumber=X
3. add some housebound details, fill out all the fields
4. Go to 'Add a new delivery'
5. No housebound details, hard to know what the patron likes or days to deliver!
6. apply patch
7. Go to 'Add a delivery'
8. See the housebound details, yay! All the line breaks should be preserved.

Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com>
Comment 7 Katrin Fischer 2021-09-26 12:34:38 UTC
Created attachment 125322 [details] [review]
Bug 26544: Add housebound details to delivery page

To test:
1. Turn on the housebound module
2. go to the housebound for a given patron /cgi-bin/koha/members/housebound.pl?borrowernumber=X
3. add some housebound details, fill out all the fields
4. Go to 'Add a new delivery'
5. No housebound details, hard to know what the patron likes or days to deliver!
6. apply patch
7. Go to 'Add a delivery'
8. See the housebound details, yay! All the line breaks should be preserved.

Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Jonathan Druart 2021-10-07 09:20:24 UTC
Pushed to master for 21.11, thanks to everybody involved!