Bug 26835 - Ability to remove Lost Items from Patrons Account without Checking in
Summary: Ability to remove Lost Items from Patrons Account without Checking in
Status: RESOLVED DUPLICATE of bug 32019
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-27 18:16 UTC by Kelly McElligott
Modified: 2022-11-16 11:27 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kelly McElligott 2020-10-27 18:16:08 UTC
Libraries all have unique ways of handling lost statuses.  At the moment, Koha allows libraries to remove a lost item from the patron's account when set to a lost status and also to not remove it. Great!  However, we would like to see Koha go one step forward after the library chooses to not remove the lost item from the patron's account, to allow for the item to be removed at a later date.  A preference would be to have the Batch Item Modification allow for libraries to change an item's lost status to another lost status, and also remove it from the patron's account.  Using the batch item modification will allow for libraries to do this operation in bulk ! Currently, if a library has the option to credit the patron if they do return a lost item, the library has no way of telling Koha (at check-in) don't refund, don't remove the lost status, just remove it from the patron's account.
Comment 1 Christopher Brannon 2020-10-27 19:32:17 UTC
+1
Comment 2 Michael Spagnuolo 2022-09-14 22:42:23 UTC
I would like to see this happen as well. Our library moved to fine free and we realized that the MarkLostItemsAsReturned preference actually returns the lost item removing the restriction from our Overdue notices. It would be great to have a way to remove items from patron's accounts without having to check-in the item. It would be even better if the process could be automated and not just added to batch item modification. Maybe a new preference to remove items marked as lost instead of returning them?
Comment 3 Nick Clemens 2022-11-16 11:27:59 UTC

*** This bug has been marked as a duplicate of bug 32019 ***