Bug 26846 - serial-collections page should select the expected and late serials automatically
Summary: serial-collections page should select the expected and late serials automatic...
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Serials (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Josef Moravec
URL:
Keywords:
Depends on: 17674
Blocks:
  Show dependency treegraph
 
Reported: 2020-10-28 14:03 UTC by Timothy Alexis Vass
Modified: 2020-12-10 14:19 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:
20.11.00, 20.05.07


Attachments
Bug 26846: Fix regressions - Preselect expected and late serials (1.68 KB, patch)
2020-11-10 11:34 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 26846: Fix regressions - Preselect expected and late serials (1.76 KB, patch)
2020-11-10 12:05 UTC, Timothy Alexis Vass
Details | Diff | Splinter Review
Bug 26846: Fix regressions - Preselect expected and late serials (1.81 KB, patch)
2020-11-17 18:14 UTC, Josef Moravec
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Alexis Vass 2020-10-28 14:03:16 UTC
We noticed this when upgrading from 19.05.04 to 20.05.03
Comment 1 Jonathan Druart 2020-11-10 11:30:34 UTC
Caused by
  commit 6cb8c9e4e97b0800d46ba2f5a32a3b898cf2d73a
  Bug 17674: Allow UI to delete serials in batch
Comment 2 Jonathan Druart 2020-11-10 11:34:16 UTC
Created attachment 113350 [details] [review]
Bug 26846: Fix regressions - Preselect expected and late serials

This is a follow-up for bug 17674. Expected and late serials must be
checked by default.

Test plan:
Have some serial collection and notice that the checkboxes are checked
for expected and late serials
/serials/serials-collection.pl?subscriptionid=42
Comment 3 Timothy Alexis Vass 2020-11-10 12:05:19 UTC
Created attachment 113383 [details] [review]
Bug 26846: Fix regressions - Preselect expected and late serials

This is a follow-up for bug 17674. Expected and late serials must be
checked by default.

Test plan:
Have some serial collection and notice that the checkboxes are checked
for expected and late serials
/serials/serials-collection.pl?subscriptionid=42

Signed-off-by: Timothy Alexis Vass <timothy_alexis.vass@ub.lu.se>
Comment 4 Timothy Alexis Vass 2020-11-10 12:05:47 UTC
Works as expected, thank you Joubu for making this correction.
Comment 5 Josef Moravec 2020-11-17 18:14:25 UTC
Created attachment 113755 [details] [review]
Bug 26846: Fix regressions - Preselect expected and late serials

This is a follow-up for bug 17674. Expected and late serials must be
checked by default.

Test plan:
Have some serial collection and notice that the checkboxes are checked
for expected and late serials
/serials/serials-collection.pl?subscriptionid=42

Signed-off-by: Timothy Alexis Vass <timothy_alexis.vass@ub.lu.se>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 6 Jonathan Druart 2020-11-18 11:04:10 UTC
Pushed to master for 20.11, thanks to everybody involved!
Comment 7 Andrew Fuerste-Henry 2020-12-09 20:49:58 UTC
Pushed to 20.05.x for 20.05.07
Comment 8 Victor Grousset/tuxayo 2020-12-10 14:19:14 UTC
Missing dependencies for 19.11.x, can't backport.