Bug 26865 - Double quotes in patron's data breaks patron searches
Summary: Double quotes in patron's data breaks patron searches
Status: RESOLVED DUPLICATE of bug 30063
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on: 13618 14044
Blocks:
  Show dependency treegraph
 
Reported: 2020-10-29 16:25 UTC by Lucas Gass
Modified: 2022-03-17 15:25 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lucas Gass 2020-10-29 16:25:29 UTC
To recreate:

1. Add a circulation note with double quotes like: This patron never returned "that book". 
2. Add a juvenile and try to 'search to add' under 'Guarantor information'.
3. Try searching for the patron with the circ note.
4. "Processing"...
5. It never completes the search
6. Take out the circ note and try again
7. Patron is searchable
Comment 1 Nick Clemens 2020-10-30 10:37:20 UTC
It's not just borrowernotes, address fields and more break this is as well
Comment 2 Jonathan Druart 2022-03-17 15:25:16 UTC
Will be fixed by bug 30063.

*** This bug has been marked as a duplicate of bug 30063 ***