Bug 26972 - Test suite does not pass with Elasticsearch for Item.t test
Summary: Test suite does not pass with Elasticsearch for Item.t test
Status: RESOLVED DUPLICATE of bug 27007
Alias: None
Product: Koha
Classification: Unclassified
Component: Test Suite (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Keywords:
Depends on: 26507
Blocks:
  Show dependency treegraph
 
Reported: 2020-11-09 11:22 UTC by Joonas Kylmälä
Modified: 2020-11-13 13:30 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joonas Kylmälä 2020-11-09 11:22:32 UTC
If the searchengine syspref is set to Elasticsearch then the Item.t test doesn't pass:

> root@kohadevbox:koha(master)$ prove t/db_dependent/Koha/Item.t
> t/db_dependent/Koha/Item.t .. 1/7 Use of uninitialized value $code_wanted in string eq at /usr/share/perl5/MARC/Field.pm line 314.
> Use of uninitialized value $code_wanted in string eq at /usr/share/perl5/MARC/Field.pm line 314.
> Use of uninitialized value $code_wanted in string eq at /usr/share/perl5/MARC/Field.pm line 314.
> Use of uninitialized value $code_wanted in string eq at /usr/share/perl5/MARC/Field.pm line 314.
> Use of uninitialized value $code_wanted in string eq at /usr/share/perl5/MARC/Field.pm line 314.
> Use of uninitialized value $code_wanted in string eq at /usr/share/perl5/MARC/Field.pm line 314.
> Use of uninitialized value $code_wanted in string eq at /usr/share/perl5/MARC/Field.pm line 314.
> Use of uninitialized value $code_wanted in string eq at /usr/share/perl5/MARC/Field.pm line 314.
> Use of uninitialized value $code_wanted in string eq at /usr/share/perl5/MARC/Field.pm line 314.
> Use of uninitialized value $code_wanted in string eq at /usr/share/perl5/MARC/Field.pm line 314.
> Use of uninitialized value $code_wanted in string eq at /usr/share/perl5/MARC/Field.pm line 314.
> Use of uninitialized value $code_wanted in string eq at /usr/share/perl5/MARC/Field.pm line 314.
> Use of uninitialized value $code_wanted in string eq at /usr/share/perl5/MARC/Field.pm line 314.
> 
>     #   Failed test 'Value is mapped correctly for column biblionumber'
>     #   at t/db_dependent/Koha/Item.t line 115.
>     #          got: undef
>     #     expected: '441'
Comment 1 David Nind 2020-11-09 19:41:56 UTC
Can confirm (master, koha-testing-docker, ku).
Comment 2 Jonathan Druart 2020-11-10 08:59:55 UTC
Caused by
  commit af9938c43feaa76bf1b1bb0a0e4b21ff7fbbe449
  Bug 26507: Elasticsearch - Index records after storing new item