Bug 27279 - "Checked out by" not populated on issuehistory.pl
Summary: "Checked out by" not populated on issuehistory.pl
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 23916
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-18 14:22 UTC by Séverine Queune
Modified: 2021-10-08 11:56 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:
21.11.00


Attachments
Bug 27279: (bug 23916 follow-up) Fix issuer display on "Checkout history" (1.76 KB, patch)
2021-09-20 09:22 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 27279: (bug 23916 follow-up) Fix issuer display on "Checkout history" (1.83 KB, patch)
2021-09-20 12:03 UTC, Andrew Fuerste-Henry
Details | Diff | Splinter Review
Bug 27279: (bug 23916 follow-up) Fix issuer display on "Checkout history" (1.89 KB, patch)
2021-09-26 13:10 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Séverine Queune 2020-12-18 14:22:46 UTC
Activating the sypref RecordStaffUserOnCheckout, the librarian who checked out the item is not displayed on "Checkout history" tab on biblio view as it's described in release notes for bug 23916.
Comment 1 Katrin Fischer 2021-01-21 20:16:06 UTC
I believe this will only be available for checkouts after this was turned on (the data is not recorded before). Would you mind testing if that was the issue?
Comment 2 Sally 2021-08-13 10:30:09 UTC
I've tested this on a sandbox (current version, 21.06) and on our test server (20.11), and the error is valid on both.

The setting is turned on.

The checked out by information correctly populates in the patron's circulation history, but not in the item checkout history: /cgi-bin/koha/catalogue/issuehistory.pl
Comment 3 Andrew Fuerste-Henry 2021-09-16 17:12:37 UTC
Can confirm this issue exists in 21.05. I performed a checkout AFTER turning on the syspref. I see "Checked out by" in the patron history but not the item history.
Comment 4 Jonathan Druart 2021-09-20 09:07:15 UTC
Caused by
  commit 61a39b0dd52df4f6d743671823449e265d6add26
  Bug 23916: (QA follow-up) Adapt all the things to the new column and accessor names

- [% INCLUDE 'patron-title.inc' patron=checkout.issued_by %]

+ [% INCLUDE 'patron-title.inc' patron=checkout.issuer_id %]
Comment 5 Jonathan Druart 2021-09-20 09:22:03 UTC
Created attachment 125048 [details] [review]
Bug 27279: (bug 23916 follow-up) Fix issuer display on "Checkout history"

Caused by
  commit 61a39b0dd52df4f6d743671823449e265d6add26
  Bug 23916: (QA follow-up) Adapt all the things to the new column and accessor names

- [% INCLUDE 'patron-title.inc' patron=checkout.issued_by %]

+ [% INCLUDE 'patron-title.inc' patron=checkout.issuer_id %]

It must have been patron=checkout.issuer as patron-title.inc is
expecting a Koha::Patron object, not a borrowernumber.

Test plan:
Turn RecordStaffUserOnCheckout on
Check an item out then in
Go to the biblio checkout history and confirm that the "Checked out by"
column contains the logged in librarian's name.
Comment 6 Andrew Fuerste-Henry 2021-09-20 12:03:07 UTC
Created attachment 125056 [details] [review]
Bug 27279: (bug 23916 follow-up) Fix issuer display on "Checkout history"

Caused by
  commit 61a39b0dd52df4f6d743671823449e265d6add26
  Bug 23916: (QA follow-up) Adapt all the things to the new column and accessor names

- [% INCLUDE 'patron-title.inc' patron=checkout.issued_by %]

+ [% INCLUDE 'patron-title.inc' patron=checkout.issuer_id %]

It must have been patron=checkout.issuer as patron-title.inc is
expecting a Koha::Patron object, not a borrowernumber.

Test plan:
Turn RecordStaffUserOnCheckout on
Check an item out then in
Go to the biblio checkout history and confirm that the "Checked out by"
column contains the logged in librarian's name.

Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com>
Comment 7 Andrew Fuerste-Henry 2021-09-20 12:05:03 UTC
Very minor quibble, in patron circ history we only show first and last name of the person who did the checkout. In the bib's checkout history we're now showing first name, last name, and cardnumber. Didn't seem worth holding up a signoff.
Comment 8 Katrin Fischer 2021-09-26 13:10:47 UTC
Created attachment 125330 [details] [review]
Bug 27279: (bug 23916 follow-up) Fix issuer display on "Checkout history"

Caused by
  commit 61a39b0dd52df4f6d743671823449e265d6add26
  Bug 23916: (QA follow-up) Adapt all the things to the new column and accessor names

- [% INCLUDE 'patron-title.inc' patron=checkout.issued_by %]

+ [% INCLUDE 'patron-title.inc' patron=checkout.issuer_id %]

It must have been patron=checkout.issuer as patron-title.inc is
expecting a Koha::Patron object, not a borrowernumber.

Test plan:
Turn RecordStaffUserOnCheckout on
Check an item out then in
Go to the biblio checkout history and confirm that the "Checked out by"
column contains the logged in librarian's name.

Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 9 Jonathan Druart 2021-09-28 13:38:04 UTC
Pushed to master for 21.11, thanks to everybody involved!