Bug 27471 - Improve link text when successfully merging authorities and remove JS redirect
Summary: Improve link text when successfully merging authorities and remove JS redirect
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Amy King
QA Contact: Kyle M Hall
URL:
Keywords: Academy
Depends on:
Blocks: 26722
  Show dependency treegraph
 
Reported: 2021-01-20 00:54 UTC by Aleisha Amohia
Modified: 2021-06-14 21:35 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: String patch
Text to go in the release notes:
Version(s) released in:
21.05.00


Attachments
Bug 27471: Link text change so is more helpful. (1.37 KB, patch)
2021-01-20 02:11 UTC, Amy King
Details | Diff | Splinter Review
Bug 27471: changed link text (1.31 KB, patch)
2021-01-20 20:38 UTC, Amy King
Details | Diff | Splinter Review
Bug 27471: changed link text (1.36 KB, patch)
2021-01-21 00:16 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 27471: redirects user to page, link text changed (1.48 KB, patch)
2021-01-21 21:24 UTC, Amy King
Details | Diff | Splinter Review
Bug 27471: Change auth merge success link text and don't redirect (1.55 KB, patch)
2021-01-21 22:56 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 27471: Change auth merge success link text and don't redirect (1.62 KB, patch)
2021-01-22 11:47 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Aleisha Amohia 2021-01-20 00:54:23 UTC
<script>window.location.href="/cgi-bin/koha/authorities/detail.pl?authid=[% recordid1 | html %]";</script>
koha-tmpl/intranet-tmpl/prog/en/modules/authorities/merge.tt:    <p>The merging was successful. <a href="/cgi-bin/koha/authorities/detail.pl?authid=[% recordid1 | uri %]">Click here to see the merged record.</a></p>

"Here" should not be used as a link text as it doesn't contain any helpful information for people scanning the page for information and also is a problem for blind users using screen readers jumping from link to link on a page.

To reproduce:
1. Create or have two authorities
2. Do a search in Authorities
3. Click Actions -> merge for one authority
4. After the page reloads to show we are merging, click Actions -> Merge for the next authority
5. Go Next until the merge is complete

Notice you don't even see the 'The merging was successful' message, because of the javascript that redirects you.

To patch:
delete the script line and reword the 'Click here' message
Comment 1 Amy King 2021-01-20 02:11:01 UTC
Created attachment 115399 [details] [review]
Bug 27471: Link text change so is more helpful.

Test PLan:
1. Complete the above steps to reproduce, specially noting the last step
2. Apply the patch
3. Complete step 1 again, but now notice how the links says "This
sentence is the link to ..."
Comment 2 Owen Leonard 2021-01-20 16:02:27 UTC
"This sentence is the link to see the merged record." doesn't make sense to me.

How about "View the merged record" ?
Comment 3 Amy King 2021-01-20 20:38:31 UTC
Created attachment 115457 [details] [review]
Bug 27471: changed link text

Test plan:
1. Complete the steps above to reproduce, specially noting the last step
2. Apply the path
3. Complete step 1 again, but now notice how the link says "View the
merged record"
Comment 4 Owen Leonard 2021-01-21 00:16:38 UTC
Created attachment 115480 [details] [review]
Bug 27471: changed link text

Test plan:
1. Complete the steps above to reproduce, specially noting the last step
2. Apply the path
3. Complete step 1 again, but now notice how the link says "View the
merged record"

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 5 Kyle M Hall 2021-01-21 18:41:44 UTC
The description of this bug indicates the javascript redirect would be removed. Please implement that change in the patch set, or alter the bug description to match the patch behavior.

Thanks!
Comment 6 Amy King 2021-01-21 21:24:54 UTC
Created attachment 115622 [details] [review]
Bug 27471: redirects user to page, link text changed

Test Plan:
1. Follow the steps above to reproduce
2. Notice how there is no message telling the user that the merge was
successsful
3. Apply patch
4. Repeat step 1
5. Now notice how the user is redirected to a page with a message that
says that the merge was successful, and there is a link with helpful
text to view the merged record
Comment 7 Katrin Fischer 2021-01-21 22:54:32 UTC
I wonder if the link and the redirect where thought to work as some kind of non-Javascript fallback? 

If Javascript is enabled, redirect automatically... if not, display the link. 

But seeing a success message is nice too!
Comment 8 Katrin Fischer 2021-01-21 22:56:02 UTC
Created attachment 115639 [details] [review]
Bug 27471: Change auth merge success link text and don't redirect

Test Plan:
1. Follow the steps above to reproduce
2. Notice how there is no message telling the user that the merge was
successsful
3. Apply patch
4. Repeat step 1
5. Now notice how the user is redirected to a page with a message that
says that the merge was successful, and there is a link with helpful
text to view the merged record

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 9 Kyle M Hall 2021-01-22 11:47:41 UTC
Created attachment 115678 [details] [review]
Bug 27471: Change auth merge success link text and don't redirect

Test Plan:
1. Follow the steps above to reproduce
2. Notice how there is no message telling the user that the merge was
successsful
3. Apply patch
4. Repeat step 1
5. Now notice how the user is redirected to a page with a message that
says that the merge was successful, and there is a link with helpful
text to view the merged record

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 10 Jonathan Druart 2021-01-27 13:37:46 UTC
Pushed to master for 21.05, thanks to everybody involved!
Comment 11 Fridolin Somers 2021-01-29 14:56:17 UTC
Enhancement not pushed to 20.11.x