Bug 27475 - Improve link text to define a patron card printer profile if none are defined
Summary: Improve link text to define a patron card printer profile if none are defined
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: James O'Keeffe
QA Contact: Testopia
URL:
Keywords: Academy
Depends on:
Blocks: 26722
  Show dependency treegraph
 
Reported: 2021-01-20 01:38 UTC by Aleisha Amohia
Modified: 2021-06-14 21:34 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: String patch
Text to go in the release notes:
Version(s) released in:
21.05.00


Attachments
Bug 27475 - Improve link text to define a patron card printer profile if none are defined (1.73 KB, patch)
2021-01-20 02:19 UTC, James O'Keeffe
Details | Diff | Splinter Review
Bug 27475: Improve link text to define a patron card printer profile if none are defined (1.78 KB, patch)
2021-01-20 16:21 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 27475: Improve link text to define a patron card printer profile if none are defined (1.84 KB, patch)
2021-01-21 09:31 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Aleisha Amohia 2021-01-20 01:38:52 UTC
koha-tmpl/intranet-tmpl/prog/en/modules/patroncards/edit-template.tt:                                        <a href="/cgi-bin/koha/patroncards/edit-profile.pl?op=new">Click here to define a printer profile.</a>

"Here" should not be used as a link text as it doesn't contain any helpful information for people scanning the page for information and also is a problem for blind users using screen readers jumping from link to link on a page.

to reproduce:
go to Tools -> patron card creator
ensure you have no printer profiles
go to add a new card template
notice that next to Profile there is a 'click here' link

we want to reword this.
Comment 1 James O'Keeffe 2021-01-20 02:19:50 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2021-01-20 16:21:02 UTC
Created attachment 115447 [details] [review]
Bug 27475: Improve link text to define a patron card printer profile if none are defined

This patch changes the text on the text link for defining a printer
profile to make it more clear. It does this by removing the "Click
here".

Test plan:
1. Navigate from home -> tools -> patron card creator
2. Ensure you have no printer profiles
3. Select "new", and create a new card template
4. Note the text link "Click here to define a new printer profile"
5. Apply the patch, and repeat steps 1-3
6. Note that the "Click here" has been removed.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 3 Martin Renvoize 2021-01-21 09:31:30 UTC
Created attachment 115513 [details] [review]
Bug 27475: Improve link text to define a patron card printer profile if none are defined

This patch changes the text on the text link for defining a printer
profile to make it more clear. It does this by removing the "Click
here".

Test plan:
1. Navigate from home -> tools -> patron card creator
2. Ensure you have no printer profiles
3. Select "new", and create a new card template
4. Note the text link "Click here to define a new printer profile"
5. Apply the patch, and repeat steps 1-3
6. Note that the "Click here" has been removed.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 4 Martin Renvoize 2021-01-21 09:31:55 UTC
Welcome to the team James :)

Passing QA
Comment 5 Jonathan Druart 2021-01-21 15:25:46 UTC
Pushed to master for 21.05, thanks to everybody involved!
Comment 6 Fridolin Somers 2021-01-25 15:34:43 UTC
I propose not to backport since it is still in work (children of Bug 26722)

Enhancement not pushed to 20.11.x