Bug 27538 - Cells in the bottom filtering row of the "Holds to pull" table shifted
Summary: Cells in the bottom filtering row of the "Holds to pull" table shifted
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Peter Vashchuk
QA Contact: Testopia
URL:
Keywords:
Depends on: 23485
Blocks:
  Show dependency treegraph
 
Reported: 2021-01-24 19:44 UTC by Peter Vashchuk
Modified: 2021-02-11 21:49 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:
21.05.00,20.11.03,20.05.09


Attachments
Bug 27538: fix correlation of fields in Holds to Pull table (3.48 KB, patch)
2021-01-24 19:46 UTC, Peter Vashchuk
Details | Diff | Splinter Review
Bug 27538: fix correlation of fields in Holds to Pull table (3.57 KB, patch)
2021-01-25 14:45 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 27538: fix correlation of fields in Holds to Pull table (3.63 KB, patch)
2021-01-31 13:16 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Vashchuk 2021-01-24 19:44:29 UTC

    
Comment 1 Peter Vashchuk 2021-01-24 19:46:14 UTC
Created attachment 115730 [details] [review]
Bug 27538: fix correlation of fields in Holds to Pull table

Bottom filtering row of "Holds to pull" table do not correlate to other ones, columns diverged from "Call numbers" cell: it should be under "Available call numbers" while it's under "Available barcodes", and so on to the last cell (while number of cells still adjusted).

To reproduce:
    1) Head to the Holds to Pull page, check that bottom filtering row shifted to the left by one, starting from the "Call number" column and don't correlate to the upper table (for example, "Call numbers" cell should be under "Available call numbers" while it's under "Available barcodes"), and so on for all cells till the end of the filtering row.
    2) Apply patch.
    3) Refresh Holds to Pull page and ensure that all filtering row columns correlate to other rows columns correctly.
Comment 2 Owen Leonard 2021-01-25 14:45:07 UTC
Created attachment 115777 [details] [review]
Bug 27538: fix correlation of fields in Holds to Pull table

Bottom filtering row of "Holds to pull" table do not correlate to other
ones, columns diverged from "Call numbers" cell: it should be under
"Available call numbers" while it's under "Available barcodes", and so
on to the last cell (while number of cells still adjusted).

To reproduce:
   1) Head to the Holds to Pull page, check that bottom filtering row
      shifted to the left by one, starting from the "Call number"
      column and don't correlate to the upper table (for example, "Call
      numbers" cell should be under "Available call numbers" while it's
      under "Available barcodes"), and so on for all cells till the end
      of the filtering row.
   2) Apply patch.
   3) Refresh Holds to Pull page and ensure that all filtering row
      columns correlate to other rows columns correctly.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 3 Katrin Fischer 2021-01-31 13:16:18 UTC
Created attachment 116100 [details] [review]
Bug 27538: fix correlation of fields in Holds to Pull table

Bottom filtering row of "Holds to pull" table do not correlate to other
ones, columns diverged from "Call numbers" cell: it should be under
"Available call numbers" while it's under "Available barcodes", and so
on to the last cell (while number of cells still adjusted).

To reproduce:
   1) Head to the Holds to Pull page, check that bottom filtering row
      shifted to the left by one, starting from the "Call number"
      column and don't correlate to the upper table (for example, "Call
      numbers" cell should be under "Available call numbers" while it's
      under "Available barcodes"), and so on for all cells till the end
      of the filtering row.
   2) Apply patch.
   3) Refresh Holds to Pull page and ensure that all filtering row
      columns correlate to other rows columns correctly.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 4 Jonathan Druart 2021-02-01 16:17:55 UTC
Caused by:
  commit fe84c3acba33af7a2fb27643f6b5f9129c329b36
  Bug 23485: Show barcode in holds to pull
Comment 5 Jonathan Druart 2021-02-01 16:27:01 UTC
Pushed to master for 21.05, thanks to everybody involved!
Comment 6 Fridolin Somers 2021-02-05 16:11:45 UTC
Pushed to 20.11.x for 20.11.03
Comment 7 Andrew Fuerste-Henry 2021-02-09 21:19:42 UTC
Pushed to 20.05.x for 20.05.09
Comment 8 Victor Grousset/tuxayo 2021-02-11 03:09:01 UTC
Missing dependencies for 19.11.x, it shouldn't be affected, no backport.