Bug 27608 - Correct 'accepted by' inconsistency in suggestion.tt
Summary: Correct 'accepted by' inconsistency in suggestion.tt
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Blou
QA Contact: Testopia
URL:
Keywords:
Depends on: 23590
Blocks:
  Show dependency treegraph
 
Reported: 2021-02-03 16:45 UTC by Blou
Modified: 2021-02-21 00:16 UTC (History)
8 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:
21.05.00,20.11.03,20.05.09


Attachments
Bug 27608: Corrects 'accepted by' inconsistency in suggestion.tt (2.30 KB, patch)
2021-02-03 16:47 UTC, Blou
Details | Diff | Splinter Review
Bug 27608: Corrects 'accepted by' inconsistency in suggestion.tt (2.36 KB, patch)
2021-02-04 21:18 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 27608: Corrects 'accepted by' inconsistency in suggestion.tt (2.41 KB, patch)
2021-02-06 22:47 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 27608: Corrects 'accepted by' inconsistency in suggestion.tt (2.47 KB, patch)
2021-02-08 13:52 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 27608: [20.05] Corrects 'accepted by' inconsistency in suggestion.tt (2.76 KB, patch)
2021-02-18 10:18 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Blou 2021-02-03 16:45:21 UTC
When looking at an accepted suggestion in suggestion.pl, under 'Suggestion management', the displayed cardnumber in parenthesis is the wrong one.  It displays the "suggestedby"'s cardnumber instead of the acceptedby.

Test:
- create a suggestion in OPAC or staff client with user A.
- In staff client, go to accept it with User B.
- Click Edit
- Under section "Suggestion management", you have a "Accepted on".
- In the By column, the cardnumber in parenthsis is not the B one.
- Apply patch, refresh.

Looking at the code patch is self-explanatory.
Comment 1 Blou 2021-02-03 16:47:38 UTC
Created attachment 116288 [details] [review]
Bug 27608: Corrects 'accepted by' inconsistency in suggestion.tt

When looking at an accepted suggestion in suggestion.pl, under 'Suggestion management', the displayed cardnumber in parenthesis is the wrong one.  It displays the "suggestedby"'s cardnumber instead of the acceptedby.

Test:
- create a suggestion in OPAC or staff client with user A.
- In staff client, go to accept it with User B.
- Click Edit
- Under section "Suggestion management", you have a "Accepted on".
- In the By column, the cardnumber in parenthsis is not the B one.
- Apply patch, refresh.

Looking at the code patch is self-explanatory.
Comment 2 Blou 2021-02-03 16:49:03 UTC
Sponsored by: Collecto

(formerly CCSR)
Comment 3 Lucas Gass 2021-02-04 21:18:09 UTC
Created attachment 116341 [details] [review]
Bug 27608: Corrects 'accepted by' inconsistency in suggestion.tt

When looking at an accepted suggestion in suggestion.pl, under 'Suggestion management', the displayed cardnumber in parenthesis is the wrong one.  It displays the "suggestedby"'s cardnumber instead of the acceptedby.

Test:
- create a suggestion in OPAC or staff client with user A.
- In staff client, go to accept it with User B.
- Click Edit
- Under section "Suggestion management", you have a "Accepted on".
- In the By column, the cardnumber in parenthsis is not the B one.
- Apply patch, refresh.

Looking at the code patch is self-explanatory.

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>
Comment 4 Katrin Fischer 2021-02-06 22:47:01 UTC
Created attachment 116450 [details] [review]
Bug 27608: Corrects 'accepted by' inconsistency in suggestion.tt

When looking at an accepted suggestion in suggestion.pl, under 'Suggestion management', the displayed cardnumber in parenthesis is the wrong one.  It displays the "suggestedby"'s cardnumber instead of the acceptedby.

Test:
- create a suggestion in OPAC or staff client with user A.
- In staff client, go to accept it with User B.
- Click Edit
- Under section "Suggestion management", you have a "Accepted on".
- In the By column, the cardnumber in parenthsis is not the B one.
- Apply patch, refresh.

Looking at the code patch is self-explanatory.

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Katrin Fischer 2021-02-06 22:47:25 UTC
Excellent catch :)
Comment 6 Jonathan Druart 2021-02-08 13:50:35 UTC
Caused by
  commit 0370e0dcd2585c3de0245718c6da43ad86f82ae8
  Bug 23590: Clean TT variables for patrons
Comment 7 Jonathan Druart 2021-02-08 13:52:34 UTC
Created attachment 116499 [details] [review]
Bug 27608: Corrects 'accepted by' inconsistency in suggestion.tt

When looking at an accepted suggestion in suggestion.pl, under 'Suggestion management', the displayed cardnumber in parenthesis is the wrong one.  It displays the "suggestedby"'s cardnumber instead of the acceptedby.

Test:
- create a suggestion in OPAC or staff client with user A.
- In staff client, go to accept it with User B.
- Click Edit
- Under section "Suggestion management", you have a "Accepted on".
- In the By column, the cardnumber in parenthsis is not the B one.
- Apply patch, refresh.

Looking at the code patch is self-explanatory.

Sponsored-by: Collecto

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

JD Amended patch: Add sponsor line
Comment 8 Jonathan Druart 2021-02-08 13:58:08 UTC
Pushed to master for 21.05, thanks to everybody involved!
Comment 9 Fridolin Somers 2021-02-12 13:37:53 UTC
Pushed to 20.11.x for 20.11.03
Comment 10 Andrew Fuerste-Henry 2021-02-17 22:23:37 UTC
Doesn't apply cleanly to 20.05. Please rebase. Thanks!
Comment 11 Jonathan Druart 2021-02-18 10:18:43 UTC
Created attachment 116974 [details] [review]
Bug 27608: [20.05] Corrects 'accepted by' inconsistency in suggestion.tt

When looking at an accepted suggestion in suggestion.pl, under 'Suggestion management', the displayed cardnumber in parenthesis is the wrong one.  It displays the "suggestedby"'s cardnumber instead of the acceptedby.

Test:
- create a suggestion in OPAC or staff client with user A.
- In staff client, go to accept it with User B.
- Click Edit
- Under section "Suggestion management", you have a "Accepted on".
- In the By column, the cardnumber in parenthsis is not the B one.
- Apply patch, refresh.

Looking at the code patch is self-explanatory.

Sponsored-by: Collecto

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

JD Amended patch: Add sponsor line
Comment 12 Andrew Fuerste-Henry 2021-02-18 12:24:01 UTC
Pushed to 20.05.x for 20.05.09. Thanks!
Comment 13 Victor Grousset/tuxayo 2021-02-21 00:16:02 UTC
Not backported to oldoldstable (19.11.x). Feel free to ask if it's needed.