Bug 27713 - Duplicate search field IDs in MARC framework administration template
Summary: Duplicate search field IDs in MARC framework administration template
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on: 25954
Blocks:
  Show dependency treegraph
 
Reported: 2021-02-16 13:43 UTC by Owen Leonard
Modified: 2021-03-19 00:07 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:
21.05.00,20.11.04,20.05.10


Attachments
Bug 27713: Duplicate search field IDs in MARC framework administration template (1.75 KB, patch)
2021-02-16 13:51 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 27713: Duplicate search field IDs in MARC framework administration template (1.80 KB, patch)
2021-02-20 23:27 UTC, Phil Ringnalda
Details | Diff | Splinter Review
Bug 27713: Duplicate search field IDs in MARC framework administration template (1.86 KB, patch)
2021-02-22 16:06 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2021-02-16 13:43:06 UTC
The "search for tag" field in MARC framework administration has the same ID as "search system preferences" field in the header search box. This is invalid and can cause problems when references elements by ID in JavaScript or CSS.
Comment 1 Owen Leonard 2021-02-16 13:51:28 UTC
Created attachment 116925 [details] [review]
Bug 27713: Duplicate search field IDs in MARC framework administration template

This patch makes a minor change to the MARC framework administration
template so that the ID of a form field on the page isn't a duplicate of
one in the header search form.

To test, apply the patch and go to Administration -> MARC bibliographic
framework -> MARC structure.

- Test the "Search for tag" form field to confirm that it works
  correctly.
- Validate the HTML of the page to confirm that there are no "Duplicate
  ID" errors.
Comment 2 Phil Ringnalda 2021-02-20 23:27:37 UTC
Created attachment 117121 [details] [review]
Bug 27713: Duplicate search field IDs in MARC framework administration template

This patch makes a minor change to the MARC framework administration
template so that the ID of a form field on the page isn't a duplicate of
one in the header search form.

To test, apply the patch and go to Administration -> MARC bibliographic
framework -> MARC structure.

- Test the "Search for tag" form field to confirm that it works
  correctly.
- Validate the HTML of the page to confirm that there are no "Duplicate
  ID" errors.

Signed-off-by: Phil Ringnalda <phil@chetcolibrary.org>
Comment 3 Martin Renvoize 2021-02-22 16:06:22 UTC
Created attachment 117161 [details] [review]
Bug 27713: Duplicate search field IDs in MARC framework administration template

This patch makes a minor change to the MARC framework administration
template so that the ID of a form field on the page isn't a duplicate of
one in the header search form.

To test, apply the patch and go to Administration -> MARC bibliographic
framework -> MARC structure.

- Test the "Search for tag" form field to confirm that it works
  correctly.
- Validate the HTML of the page to confirm that there are no "Duplicate
  ID" errors.

Signed-off-by: Phil Ringnalda <phil@chetcolibrary.org>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 4 Martin Renvoize 2021-02-22 16:06:39 UTC
Always good to improve these things.. Passing QA
Comment 5 Jonathan Druart 2021-02-23 12:22:18 UTC
Pushed to master for 21.05, thanks to everybody involved!
Comment 6 Fridolin Somers 2021-02-25 09:50:24 UTC
Pushed to 20.11.x for 20.11.04
Comment 7 Andrew Fuerste-Henry 2021-03-05 17:05:08 UTC
Pushed to 20.05.x for 20.05.10
Comment 8 Victor Grousset/tuxayo 2021-03-19 00:07:36 UTC
Not backported to oldoldstable (19.11.x). Feel free to ask if it's needed.