Bug 27900 - regression: add from existing record with null results deadends
Summary: regression: add from existing record with null results deadends
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Katrin Fischer
URL:
Keywords:
Depends on: 24347
Blocks:
  Show dependency treegraph
 
Reported: 2021-03-08 19:34 UTC by Donna
Modified: 2021-04-24 17:19 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:
21.05.00,20.11.05,20.05.11


Attachments
Bug 27900: Add a link back to the basket view if no result (1.92 KB, patch)
2021-03-11 14:06 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 27900: Add a link back to the basket view if no result (2.07 KB, patch)
2021-04-02 09:33 UTC, Séverine Queune
Details | Diff | Splinter Review
Bug 27900: Add a link back to the basket view if no result (2.12 KB, patch)
2021-04-02 16:11 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 27900: (QA follow-up) Add missing filter (1.69 KB, patch)
2021-04-02 16:11 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 27900: (QA follow-up) Rephrase link text (1.72 KB, patch)
2021-04-02 16:11 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Donna 2021-03-08 19:34:49 UTC
Prior to 20.05, when adding to a basket in acquisitions from an existing record, a search with no results left the user at /acqui/neworderbiblio.pl where they could then add to the basket via external source, etc.  In 20.05 the user now ends at catalogue/search.pl and has to use the back button to return to the vendors list, and access the basket again.
Comment 1 Christopher Brannon 2021-03-09 22:51:42 UTC
Confirmed!  We found this bug.
Comment 2 Jonathan Druart 2021-03-11 14:06:36 UTC
Created attachment 118126 [details] [review]
Bug 27900: Add a link back to the basket view if no result

Since bug 24347 the neworderbiblio view has been removed and we now
display the usual search result.
When adding a new order from a search, if there is no result we should
let the user get back to the basket view.

Test plan:
Add to basket from an existing record
Do a search with no results and confirm that there is a new "Go to the
basket view" link
Comment 3 Jonathan Druart 2021-03-11 14:07:17 UTC
Does this patch meet your needs?
Comment 4 Séverine Queune 2021-04-02 09:33:15 UTC
Created attachment 119107 [details] [review]
Bug 27900: Add a link back to the basket view if no result

Since bug 24347 the neworderbiblio view has been removed and we now
display the usual search result.
When adding a new order from a search, if there is no result we should
let the user get back to the basket view.

Test plan:
Add to basket from an existing record
Do a search with no results and confirm that there is a new "Go to the
basket view" link

Signed-off-by: Séverine QUEUNE <severine.queune@bulac.fr>
Comment 5 Séverine Queune 2021-04-02 09:34:17 UTC
I never noticed that problem, nice catch Donna, and thank you Jonathan for fixing it, to me it works fine !
Comment 6 Katrin Fischer 2021-04-02 16:11:25 UTC
Created attachment 119133 [details] [review]
Bug 27900: Add a link back to the basket view if no result

Since bug 24347 the neworderbiblio view has been removed and we now
display the usual search result.
When adding a new order from a search, if there is no result we should
let the user get back to the basket view.

Test plan:
Add to basket from an existing record
Do a search with no results and confirm that there is a new "Go to the
basket view" link

Signed-off-by: Séverine QUEUNE <severine.queune@bulac.fr>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Katrin Fischer 2021-04-02 16:11:30 UTC
Created attachment 119134 [details] [review]
Bug 27900: (QA follow-up) Add missing filter

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Katrin Fischer 2021-04-02 16:11:34 UTC
Created attachment 119135 [details] [review]
Bug 27900: (QA follow-up) Rephrase link text

See discussion on IRC from today :)

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 9 Jonathan Druart 2021-04-06 13:58:08 UTC
Pushed to master for 21.05, thanks to everybody involved!
Comment 10 Fridolin Somers 2021-04-15 10:42:24 UTC
Pushed to 20.11.x for 20.11.05
Comment 11 Christopher Brannon 2021-04-15 14:57:52 UTC
Are we able to get this ported back to 20.05?
Comment 12 Andrew Fuerste-Henry 2021-04-24 16:57:37 UTC
Pushed to 20.05.x for 20.05.11
Comment 13 Victor Grousset/tuxayo 2021-04-24 17:19:00 UTC
Not backported to oldoldstable (19.11.x). Feel free to ask if it's needed.