Bug 28124 - Changing an expiration date changes ALL expiration dates
Summary: Changing an expiration date changes ALL expiration dates
Status: RESOLVED DUPLICATE of bug 26429
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low blocker (vote)
Assignee: Didier Gautheron
QA Contact: Testopia
URL:
Keywords:
Depends on: 25789
Blocks:
  Show dependency treegraph
 
Reported: 2021-04-09 14:34 UTC by Didier Gautheron
Modified: 2021-04-13 09:03 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Didier Gautheron 2021-04-09 14:34:53 UTC
Hi,

Since 25789 if an item has more than one hold changing one expiration date change all expiration dates in koha/reserve/request.pl
Comment 1 Fridolin Somers 2021-04-09 15:01:58 UTC
We propose to revert Bug 25789 from stable branches
Comment 2 Jonathan Druart 2021-04-12 08:46:07 UTC
I don't recreate the issue on master, please provide more details. Which exact koha version, which screen, which conditions?
https://snipboard.io/PL3KUr.jpg
Comment 3 Julian Maurice 2021-04-12 09:10:25 UTC
(In reply to Jonathan Druart from comment #2)
> I don't recreate the issue on master, please provide more details. Which
> exact koha version, which screen, which conditions?
> https://snipboard.io/PL3KUr.jpg

It looks like it was already fixed by bug 26429.
The 'datepickerto' class was the issue, and bug 26429 removed it.
As it was already backported to all stable versions, I think there's nothing left to fix.
I'll let Didier & Frido confirm
Comment 4 Didier Gautheron 2021-04-13 08:33:54 UTC
Hi,

I somehow mixed up my testing on master.

It's actually fixed.

Thanks.
Comment 5 Jonathan Druart 2021-04-13 09:03:33 UTC

*** This bug has been marked as a duplicate of bug 26429 ***