Bug 28208 - ModItemTransfer no longer updates item.datelastseen
Summary: ModItemTransfer no longer updates item.datelastseen
Status: RESOLVED INVALID
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on: 24446
Blocks:
  Show dependency treegraph
 
Reported: 2021-04-23 15:25 UTC by Nick Clemens
Modified: 2022-08-22 14:03 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2021-04-23 15:25:54 UTC
Bug 24446 removed a call to ModDateLastSeen - we should blank the datelastseen before storing to update the field - or do we not need to update when calling ModItemTransfer?
Comment 1 Martin Renvoize 2021-04-23 15:57:53 UTC
ModItemTransfer is about to be removed ;).
Comment 2 Martin Renvoize 2021-04-28 13:17:18 UTC
Coming back to this... are you sure Nick?

Inside ModItemTransfer we now call the Koha::Item->request_transfer method followed by the Koha::Item::Transfer->transit method (if the item is not checked out) to immediately put it into transit.

The transit method calls 'ModDateLastSeen' internally, so this should be getting caught there and updated as expected.
Comment 3 Jonathan Druart 2021-04-30 08:31:02 UTC
What if the item is checked out? (before was bug 24446 date last seen was updated)
Comment 4 Martin Renvoize 2021-04-30 12:06:55 UTC
(In reply to Jonathan Druart from comment #3)
> What if the item is checked out? (before was bug 24446 date last seen was
> updated)

Correct.. but it's by design.  If the item is checked out when a transfer is requested upon it.. then the item hasn't actually been seen has it ;)  Pretty sure I actually discussed this at the time.. perhaps I missed someone relevant.

Nick, what is the use case/bug resulting from this change?
Comment 5 Nick Clemens 2021-05-06 09:32:29 UTC
(In reply to Martin Renvoize from comment #4)
> (In reply to Jonathan Druart from comment #3)
> > What if the item is checked out? (before was bug 24446 date last seen was
> > updated)
> 
> Correct.. but it's by design.  If the item is checked out when a transfer is
> requested upon it.. then the item hasn't actually been seen has it ;) 
> Pretty sure I actually discussed this at the time.. perhaps I missed someone
> relevant.
> 
> Nick, what is the use case/bug resulting from this change

I filed this simply because I noticed the change, I haven't heard any reports, but I wanted to confirm the change was intentional