Bug 28271 - Add the ability to set a new lost status when a claim is resolved
Summary: Add the ability to set a new lost status when a claim is resolved
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Tomás Cohen Arazi
URL:
Keywords:
: 26316 (view as bug list)
Depends on: 24279 28586
Blocks: 28588
  Show dependency treegraph
 
Reported: 2021-04-30 13:14 UTC by Jonathan Druart
Modified: 2021-06-25 14:13 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:
21.11.00


Attachments
Bug 28271: Add the ability to set a new lost status when a claim is resolved (5.14 KB, patch)
2021-04-30 13:18 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 28271: Adjust API spec (912 bytes, patch)
2021-04-30 13:22 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 28271: Preselect the current item lost value (3.26 KB, patch)
2021-05-03 14:04 UTC, Jonathan Druart
Details | Diff | Splinter Review
Proposed wording (179.34 KB, image/png)
2021-06-16 13:49 UTC, Andrew Fuerste-Henry
Details
Bug 28271: Add (current status) (968 bytes, patch)
2021-06-17 08:27 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 28271: Add the ability to set a new lost status when a claim is resolved (5.27 KB, patch)
2021-06-17 19:56 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 28271: Adjust API spec (996 bytes, patch)
2021-06-17 19:56 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 28271: Preselect the current item lost value (3.31 KB, patch)
2021-06-17 19:56 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 28271: Add (current status) (1021 bytes, patch)
2021-06-17 19:56 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 28271: Add the ability to set a new lost status when a claim is resolved (5.34 KB, patch)
2021-06-18 11:50 UTC, Andrew Fuerste-Henry
Details | Diff | Splinter Review
Bug 28271: Adjust API spec (1.04 KB, patch)
2021-06-18 11:50 UTC, Andrew Fuerste-Henry
Details | Diff | Splinter Review
Bug 28271: Preselect the current item lost value (3.38 KB, patch)
2021-06-18 11:50 UTC, Andrew Fuerste-Henry
Details | Diff | Splinter Review
Bug 28271: Add (current status) (1.13 KB, patch)
2021-06-18 11:50 UTC, Andrew Fuerste-Henry
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2021-04-30 13:14:48 UTC

    
Comment 1 Jonathan Druart 2021-04-30 13:18:18 UTC
Created attachment 120335 [details] [review]
Bug 28271: Add the ability to set a new lost status when a claim is resolved

When a claim is resolved the librarian should be able to edit the lost
status of the item.

It is also letting a way out when BlockReturnOfLostItems is set (the
lost status is stuck on ClaimReturnedLostValue as we remove the
option to edit itemlost on the item edit form).
Comment 2 Jonathan Druart 2021-04-30 13:19:57 UTC
This patch follows the discussion we had on IRC earlier today
http://irc.koha-community.org/koha/2021-04-30#i_2349886
Comment 3 Jonathan Druart 2021-04-30 13:22:04 UTC
Created attachment 120336 [details] [review]
Bug 28271: Adjust API spec
Comment 4 Andrew Fuerste-Henry 2021-04-30 13:56:28 UTC
That's really nice and slick! Three bits of feedback:
- if the lost value dropdown defaulted to the item's current status it would make it harder for folks to accidentally change it
- it would also be helpful if the dropdown noted which lost status the item is currently at, something like "Claims Returned (current status)"
- something like "Not lost" would be more clear than just a blank line
Comment 5 Jonathan Druart 2021-05-03 14:04:40 UTC
Created attachment 120406 [details] [review]
Bug 28271: Preselect the current item lost value
Comment 6 Jonathan Druart 2021-05-03 14:05:30 UTC
(In reply to Andrew Fuerste-Henry from comment #4)
> That's really nice and slick! Three bits of feedback:
> - if the lost value dropdown defaulted to the item's current status it would
> make it harder for folks to accidentally change it

Done.

> - it would also be helpful if the dropdown noted which lost status the item
> is currently at, something like "Claims Returned (current status)"

Can you retest and you detail a bit more? I am not sure I see where you want it displayed.

> - something like "Not lost" would be more clear than just a blank line

Done.
Comment 7 Jonathan Druart 2021-06-16 13:01:23 UTC
Andrew, are you happy with this patchset?
Comment 8 Andrew Fuerste-Henry 2021-06-16 13:49:32 UTC
Created attachment 122047 [details]
Proposed wording

I've attached a screenshot of the resolution interface. The item in question is currently set to the lost status cr. When resolving the claim, I'd like to see it default to maintaining the existing value. Further, it'd be helpful to have the current value noted in this dropdown. I added some wording, which I've marked with a red box. Thanks!
Comment 9 Jonathan Druart 2021-06-17 08:27:47 UTC
Created attachment 122054 [details] [review]
Bug 28271: Add (current status)
Comment 10 Jonathan Druart 2021-06-17 08:28:52 UTC
(In reply to Andrew Fuerste-Henry from comment #8)

> When resolving the claim, I'd like to see it default to maintaining the existing value.

This is how it is supposed to work already :)

> Further, it'd be helpful to have the current value noted in this dropdown. I added some wording, which I've marked with a red box.

I have added "(current status)", without the uppercase.
Comment 11 Andrew Fuerste-Henry 2021-06-17 12:24:58 UTC
(In reply to Jonathan Druart from comment #10)
> (In reply to Andrew Fuerste-Henry from comment #8)
> 
> > When resolving the claim, I'd like to see it default to maintaining the existing value.
> 
> This is how it is supposed to work already :)

This is not what it was doing yesterday (see my screenshot, that book was at status "cr" but the resolution popup defaulted to "None"). But it is working correctly as I test this morning.

> > Further, it'd be helpful to have the current value noted in this dropdown. I added some wording, which I've marked with a red box.
> 
> I have added "(current status)", without the uppercase.

Looks great, thanks!

However, this morning I went a step further and actually clicked "Resolve." In both Chrome and Firefox, when I click Resolve I get a little spinning wheel on the button that looks like Koha's working on it, but it just stops there. The browser console says ":8081/api/v1/return_claims/1/resolve:1 Failed to load resource: the server responded with a status of 400 (Bad Request)"
Comment 12 Jonathan Druart 2021-06-17 14:45:18 UTC
It's a bug in master, opened bug 28586.
Comment 13 Tomás Cohen Arazi 2021-06-17 19:56:02 UTC
Created attachment 122093 [details] [review]
Bug 28271: Add the ability to set a new lost status when a claim is resolved

When a claim is resolved the librarian should be able to edit the lost
status of the item.

It is also letting a way out when BlockReturnOfLostItems is set (the
lost status is stuck on ClaimReturnedLostValue as we remove the
option to edit itemlost on the item edit form).
Comment 14 Tomás Cohen Arazi 2021-06-17 19:56:11 UTC
Created attachment 122094 [details] [review]
Bug 28271: Adjust API spec

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 15 Tomás Cohen Arazi 2021-06-17 19:56:23 UTC
Created attachment 122095 [details] [review]
Bug 28271: Preselect the current item lost value

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 16 Tomás Cohen Arazi 2021-06-17 19:56:31 UTC
Created attachment 122096 [details] [review]
Bug 28271: Add (current status)

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 17 Andrew Fuerste-Henry 2021-06-18 11:50:03 UTC
Created attachment 122120 [details] [review]
Bug 28271: Add the ability to set a new lost status when a claim is resolved

When a claim is resolved the librarian should be able to edit the lost
status of the item.

It is also letting a way out when BlockReturnOfLostItems is set (the
lost status is stuck on ClaimReturnedLostValue as we remove the
option to edit itemlost on the item edit form).

Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com>
Comment 18 Andrew Fuerste-Henry 2021-06-18 11:50:07 UTC
Created attachment 122121 [details] [review]
Bug 28271: Adjust API spec

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com>
Comment 19 Andrew Fuerste-Henry 2021-06-18 11:50:11 UTC
Created attachment 122122 [details] [review]
Bug 28271: Preselect the current item lost value

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com>
Comment 20 Andrew Fuerste-Henry 2021-06-18 11:50:15 UTC
Created attachment 122123 [details] [review]
Bug 28271: Add (current status)

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com>

Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com>
Comment 21 Andrew Fuerste-Henry 2021-06-18 12:02:45 UTC
*** Bug 26316 has been marked as a duplicate of this bug. ***
Comment 22 Tomás Cohen Arazi 2021-06-18 12:42:58 UTC
1+1 = 2, this is PQA :-D
Comment 23 Jonathan Druart 2021-06-21 10:05:31 UTC
Pushed to master for 21.11, thanks to everybody involved!
Comment 24 Kyle M Hall 2021-06-25 13:50:16 UTC
Enhancement not backported to 20.05

Jonathan, if you think this should be backported as a bug fix, let us know!
Comment 25 Jonathan Druart 2021-06-25 14:13:32 UTC
(In reply to Kyle M Hall from comment #24)
> Enhancement not backported to 20.05
> 
> Jonathan, if you think this should be backported as a bug fix, let us know!

Ask Andrew, but I think it would be good to have it into 21.05.