Bug 28537 - Improve HTML generated by OverDrive integration
Summary: Improve HTML generated by OverDrive integration
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
: 29323 (view as bug list)
Depends on: 28536 20168
Blocks:
  Show dependency treegraph
 
Reported: 2021-06-09 16:47 UTC by Owen Leonard
Modified: 2021-11-05 18:27 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:
21.11.00


Attachments
Bug 28537: Improve HTML generated by OverDrive integration (10.64 KB, patch)
2021-06-09 19:07 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 28537: Improve HTML generated by OverDrive integration (11.11 KB, patch)
2021-09-17 15:40 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 28537: (follow-up) Correct and improve OverDrive checkout modal (5.46 KB, patch)
2021-09-17 15:40 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 28537: Improve HTML generated by OverDrive integration (11.47 KB, patch)
2021-10-15 12:19 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 28537: (follow-up) Correct and improve OverDrive checkout modal (5.46 KB, patch)
2021-10-15 12:19 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 28537: Improve HTML generated by OverDrive integration (11.53 KB, patch)
2021-10-27 11:32 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 28537: (follow-up) Correct and improve OverDrive checkout modal (5.52 KB, patch)
2021-10-27 11:32 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2021-06-09 16:47:07 UTC
OverDrive integration generates HTML in a couple of different places, and I think it could use some improvements. Especially the "OverDrive Account" tab which shows titles checked out to and on hold for a logged-in patron.
Comment 1 Owen Leonard 2021-06-09 19:07:42 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2021-09-17 15:40:53 UTC Comment hidden (obsolete)
Comment 3 Owen Leonard 2021-09-17 15:40:57 UTC Comment hidden (obsolete)
Comment 4 Owen Leonard 2021-10-15 12:19:39 UTC
Created attachment 126324 [details] [review]
Bug 28537: Improve HTML generated by OverDrive integration

This patch makes changes to the way HTML is generated when showing
output from OverDrive integration:

- Buttons have Bootstrap button classes
- Layout of information is improved.
- Handling of cover image thumbnails is improved, especially in cases
  where images were much larger than expected.
- An OverDrive-specific CSS file is added.

To test you must have valid credentials entered in system preferences
for the OverDrive API. You should test using a patron who has holds and
current checkouts in OverDrive.

Apply the patch and log in to the OPAC.

- On the "Your summary" page, open the "OverDrive Account" tab.
  - Log in to your OverDrive account.
  - The contents of the tab should display well, with item
    thumbnails showing in a column to the left, and item information
    showing to the right.
  - Controls should be styled with standard Bootstrap style.
  - Confirm that operations work correctly: Acessing titles, checking
    in, canceling holds, etc.

- Perform a catalog search which will return results also found in your
  OverDrive collection.
  - Open the OverDrive results page.
  - The page should display correctly, especially thumbnails.
  - Confirm that operations work correctly: Checking out and placing
    holds.
Comment 5 Owen Leonard 2021-10-15 12:19:42 UTC
Created attachment 126325 [details] [review]
Bug 28537: (follow-up) Correct and improve OverDrive checkout modal

This patch corrects the markup of the modal which is displayed when the
user clicks the "Download as" button in their list of OverDrive
checkouts. The modal markup had not been updated in the conversion to
Bootstrap 4.

I have also modified the markup generated when listing the download
format options so that they use some standard Bootstrap 4 classes,
improving the layout a little.

To test you must have valid credentials entered in system preferences
for the OverDrive API. You should test using a patron who has holds and
current checkouts in OverDrive.

Apply the patch and log in to the OPAC.

- On the "Your summary" page, open the "OverDrive Account" tab.
  - Log in to your OverDrive account.
  - In the list of current checkouts, click the "Download as" button for
    one of the titles.
    - A modal window should display with a list of radio buttons for
      each available format.
      - Confirm that the format text acts as the label for the radio
        button.
      - Confirm that closing the modal without making a selection works
        correctly.
      - Confirm that making a selection and submitting the form closes
        the modal and submits your choice.
Comment 6 Nick Clemens 2021-10-26 13:59:33 UTC
*** Bug 29323 has been marked as a duplicate of this bug. ***
Comment 7 Nick Clemens 2021-10-27 11:32:46 UTC
Created attachment 126969 [details] [review]
Bug 28537: Improve HTML generated by OverDrive integration

This patch makes changes to the way HTML is generated when showing
output from OverDrive integration:

- Buttons have Bootstrap button classes
- Layout of information is improved.
- Handling of cover image thumbnails is improved, especially in cases
  where images were much larger than expected.
- An OverDrive-specific CSS file is added.

To test you must have valid credentials entered in system preferences
for the OverDrive API. You should test using a patron who has holds and
current checkouts in OverDrive.

Apply the patch and log in to the OPAC.

- On the "Your summary" page, open the "OverDrive Account" tab.
  - Log in to your OverDrive account.
  - The contents of the tab should display well, with item
    thumbnails showing in a column to the left, and item information
    showing to the right.
  - Controls should be styled with standard Bootstrap style.
  - Confirm that operations work correctly: Acessing titles, checking
    in, canceling holds, etc.

- Perform a catalog search which will return results also found in your
  OverDrive collection.
  - Open the OverDrive results page.
  - The page should display correctly, especially thumbnails.
  - Confirm that operations work correctly: Checking out and placing
    holds.

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 8 Nick Clemens 2021-10-27 11:32:52 UTC
Created attachment 126970 [details] [review]
Bug 28537: (follow-up) Correct and improve OverDrive checkout modal

This patch corrects the markup of the modal which is displayed when the
user clicks the "Download as" button in their list of OverDrive
checkouts. The modal markup had not been updated in the conversion to
Bootstrap 4.

I have also modified the markup generated when listing the download
format options so that they use some standard Bootstrap 4 classes,
improving the layout a little.

To test you must have valid credentials entered in system preferences
for the OverDrive API. You should test using a patron who has holds and
current checkouts in OverDrive.

Apply the patch and log in to the OPAC.

- On the "Your summary" page, open the "OverDrive Account" tab.
  - Log in to your OverDrive account.
  - In the list of current checkouts, click the "Download as" button for
    one of the titles.
    - A modal window should display with a list of radio buttons for
      each available format.
      - Confirm that the format text acts as the label for the radio
        button.
      - Confirm that closing the modal without making a selection works
        correctly.
      - Confirm that making a selection and submitting the form closes
        the modal and submits your choice.

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 9 Nick Clemens 2021-10-27 11:33:33 UTC
Small patch, big improvement, moving to PQA
Comment 10 Jonathan Druart 2021-11-03 14:31:12 UTC
Pushed to master for 21.11, thanks to everybody involved!