Bug 28684 - Superfluous -or condition in few article request queries
Summary: Superfluous -or condition in few article request queries
Status: RESOLVED DUPLICATE of bug 29082
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-08 12:51 UTC by Marcel de Rooy
Modified: 2021-09-22 19:49 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2021-07-08 12:51:47 UTC
-                -or => [
-                    status => Koha::ArticleRequest::Status::Pending,
-                    status => Koha::ArticleRequest::Status::Processing
-                ]
+                Koha::ArticleRequest::Status::Pending,
+                Koha::ArticleRequest::Status::Processing,
Comment 1 Marcel de Rooy 2021-07-08 12:55:00 UTC
Koha/Template/Plugin/Biblio.pm

Koha/Biblio
            -or          => [
                { status => Koha::ArticleRequest::Status::Pending },
                { status => Koha::ArticleRequest::Status::Processing }

Koha/Patron
            -or          => [
                { status => Koha::ArticleRequest::Status::Pending },
                { status => Koha::ArticleRequest::Status::Processing }
            ]
Comment 2 Tomás Cohen Arazi 2021-09-22 19:18:47 UTC
Good catch, solved in the linked bugs.

*** This bug has been marked as a duplicate of bug 29082 ***