Bug 28797 - Hold reminder email should use All Libraries notice
Summary: Hold reminder email should use All Libraries notice
Status: RESOLVED DUPLICATE of bug 30667
Alias: None
Product: Koha
Classification: Unclassified
Component: Command-line Utilities (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
: 29801 (view as bug list)
Depends on: 15986
Blocks:
  Show dependency treegraph
 
Reported: 2021-08-02 13:16 UTC by Andrew Fuerste-Henry
Modified: 2022-08-16 15:15 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Fuerste-Henry 2021-08-02 13:16:10 UTC
Bug 15986 introduces a hold reminder email. It only knows how to use branch-specific notices and will fail if your only HOLD_REMINDER notice is for All Libraries.

To confirm:
- have a patron with a valid email address and Hold notices set to go out via email in their messaging prefs
- place a hold for your patron, get it to Waiting status
- confirm that you have the default HOLD_REMINDER email notice for All Libraries but no library-specific HOLD_REMINDER notice
- perl misc/cronjobs/holds/holds_reminder.pl -c -v to run the holds reminder cron
- get "Message 'HOLD_REMINDER' content not found for [your branch]"
- create the notice for your branch
- re-run the cron
- patron gets notice
Comment 1 Katrin Fischer 2022-01-09 01:55:38 UTC
*** Bug 29801 has been marked as a duplicate of this bug. ***
Comment 2 Liz Rea 2022-08-16 15:15:52 UTC

*** This bug has been marked as a duplicate of bug 30667 ***