Bug 29436 - Cannot reorder facets in staff interface elasticsearch configuration
Summary: Cannot reorder facets in staff interface elasticsearch configuration
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching - Elasticsearch (show other bugs)
Version: master
Hardware: All All
: P5 - low normal with 10 votes (vote)
Assignee: Jonathan Druart
QA Contact:
URL:
Keywords:
Depends on: 19482
Blocks:
  Show dependency treegraph
 
Reported: 2021-11-08 15:33 UTC by Nick Clemens
Modified: 2022-02-06 22:21 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.05.00,21.11.02,21.05.08


Attachments
Bug 29436: ES mappings not saved if zebra is configured (3.72 KB, patch)
2021-11-16 15:06 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 29436: ES mappings not saved if zebra is configured (3.78 KB, patch)
2021-11-19 07:32 UTC, Fridolin Somers
Details | Diff | Splinter Review
Bug 29436: ES mappings not saved if zebra is configured (3.84 KB, patch)
2021-12-17 14:38 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2021-11-08 15:33:52 UTC
On master:
Move author to bottom of list, click save
"An error occurred when updating mappings: . "

On 21.05 we are seeing that nothing happens when clicking the 'Save' button
Comment 1 Jonathan Druart 2021-11-16 15:02:11 UTC
I actually get this error when searchengine=zebra, and the message is... "elasticsearch_disabled"...
Comment 2 Jonathan Druart 2021-11-16 15:06:29 UTC
Created attachment 127697 [details] [review]
Bug 29436: ES mappings not saved if zebra is configured

The mappings must be editable even if ES is not turned on yet.

Using a separate array to store the errors as we are testing for $@ ||
@messages.

There is still something wrong that should be improve, but this patch
should be safe for backport.
Comment 3 Jonathan Druart 2021-11-16 15:07:52 UTC
Looks like it has been caused by
  commit 975e06bd7c3e198048c60d4a0f9968ba89079de7
  Bug 19482: Add support for defining 'mandatory' mappings
Comment 4 Jonathan Druart 2021-11-16 15:09:06 UTC
(In reply to Jonathan Druart from comment #2)
> There is still something wrong that should be improve, but this patch
> should be safe for backport.

hum... bug 19482 comment 70
Comment 5 Fridolin Somers 2021-11-19 07:32:23 UTC
Created attachment 127824 [details] [review]
Bug 29436: ES mappings not saved if zebra is configured

The mappings must be editable even if ES is not turned on yet.

Using a separate array to store the errors as we are testing for $@ ||
@messages.

There is still something wrong that should be improve, but this patch
should be safe for backport.

Signed-off-by: Fridolin Somers <fridolin.somers@biblibre.com>
Comment 6 Fridolin Somers 2021-11-19 07:33:10 UTC
Looks OK to me.
Comment 7 Nick Clemens 2021-12-17 14:38:00 UTC
Created attachment 128673 [details] [review]
Bug 29436: ES mappings not saved if zebra is configured

The mappings must be editable even if ES is not turned on yet.

Using a separate array to store the errors as we are testing for $@ ||
@messages.

There is still something wrong that should be improve, but this patch
should be safe for backport.

Signed-off-by: Fridolin Somers <fridolin.somers@biblibre.com>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 8 Fridolin Somers 2021-12-22 06:55:16 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄
Comment 9 Andrew Fuerste-Henry 2022-01-10 15:11:46 UTC
21.11 log shows this was pushed to 21.11.02.

Pushed to 21.05.x for 21.05.08.
Comment 10 Victor Grousset/tuxayo 2022-02-06 22:21:31 UTC
Not backported to oldoldstable (20.11.x). Feel free to ask if it's needed.