Bug 29477 - flatpickr default time should be 23:59 (11:59 pm as well, probably), not 12:00
Summary: flatpickr default time should be 23:59 (11:59 pm as well, probably), not 12:00
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Tomás Cohen Arazi
URL:
Keywords:
Depends on:
Blocks: 29239 29394
  Show dependency treegraph
 
Reported: 2021-11-15 09:14 UTC by Andrew Nugged
Modified: 2021-11-19 16:48 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
This fixes the flatpickr default time defaulting to 12:00 instead of 23:59, which was an unexpected change in behaviour caused by the flatpickr switch.
Version(s) released in:
21.11.00


Attachments
Bug 29477: Flatpickr - default to 23:59 for the time part (1.22 KB, patch)
2021-11-15 09:34 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 29477: Flatpickr - default to 23:59 for the time part (1.27 KB, patch)
2021-11-15 18:38 UTC, David Nind
Details | Diff | Splinter Review
Bug 29477: Flatpickr - default to 23:59 for the time part (1.32 KB, patch)
2021-11-16 12:05 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Nugged 2021-11-15 09:14:51 UTC
Our customers reported this UX issue: time by default set to the middle of the say (12:00) and they in all cases need to change the time manually to 23:59.
Comment 1 Jonathan Druart 2021-11-15 09:34:44 UTC
Created attachment 127623 [details] [review]
Bug 29477: Flatpickr - default to 23:59 for the time part

It was defaulting to 12:00 which was an unexpected change in behaviour
caused by flatpickr switch.

Test plan:
On the circulation view, check some items out and play with the time
part and "Remember for session". The behaviour must be correct, ie. the
same as prior to flatpickr switch.
Comment 2 David Nind 2021-11-15 18:38:18 UTC
Created attachment 127668 [details] [review]
Bug 29477: Flatpickr - default to 23:59 for the time part

It was defaulting to 12:00 which was an unexpected change in behaviour
caused by flatpickr switch.

Test plan:
On the circulation view, check some items out and play with the time
part and "Remember for session". The behaviour must be correct, ie. the
same as prior to flatpickr switch.

Signed-off-by: David Nind <david@davidnind.com>
Comment 3 Tomás Cohen Arazi 2021-11-16 12:05:13 UTC
Created attachment 127687 [details] [review]
Bug 29477: Flatpickr - default to 23:59 for the time part

It was defaulting to 12:00 which was an unexpected change in behaviour
caused by flatpickr switch.

Test plan:
On the circulation view, check some items out and play with the time
part and "Remember for session". The behaviour must be correct, ie. the
same as prior to flatpickr switch.

Signed-off-by: David Nind <david@davidnind.com>
Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 4 Tomás Cohen Arazi 2021-11-16 12:05:33 UTC
Works as expected, trivial fix.
Comment 5 Jonathan Druart 2021-11-17 08:05:39 UTC
Pushed to master for 21.11, thanks to everybody involved!