Bug 29603 - Fix responsive behavior of facets menu in OPAC search results
Summary: Fix responsive behavior of facets menu in OPAC search results
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords: rel_21_05_candidate
: 30841 (view as bug list)
Depends on: 29960
Blocks:
  Show dependency treegraph
 
Reported: 2021-11-30 16:30 UTC by Owen Leonard
Modified: 2022-11-17 23:47 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.05.00;21.11.14,21.05.21


Attachments
Screen grab showing the transition from sidebar to collapsed menu (19.11.x) (287.70 KB, image/gif)
2021-11-30 16:30 UTC, Owen Leonard
Details
Bug 29603: Fix responsive behavior of facets menu in OPAC search results (5.37 KB, patch)
2022-01-27 16:08 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 29603: Fix responsive behavior of facets menu in OPAC search results (5.42 KB, patch)
2022-01-29 05:23 UTC, David Nind
Details | Diff | Splinter Review
Bug 29603: Fix responsive behavior of facets menu in OPAC search results (5.47 KB, patch)
2022-02-14 21:26 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 29603: [21.11.x] Fix responsive behavior of facets menu in OPAC search results (5.48 KB, patch)
2022-05-26 11:02 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 29603: [20.11.x] Fix responsive behavior of facets menu in OPAC search results (4.89 KB, patch)
2022-05-26 11:34 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2021-11-30 16:30:47 UTC
Created attachment 128110 [details]
Screen grab showing the transition from sidebar to collapsed menu (19.11.x)

We have some JS in the OPAC which is supposed to help gracefully hide and show the OPAC search results facets menu at narrower browser widths. It was working in 19.11.x At some point this was broken and the menu shows below the search results.
Comment 1 Owen Leonard 2022-01-27 16:08:28 UTC Comment hidden (obsolete)
Comment 2 David Nind 2022-01-29 05:23:10 UTC
Created attachment 129967 [details] [review]
Bug 29603: Fix responsive behavior of facets menu in OPAC search results

The OPAC was originally featured a search results facets box that would
collapse at narrower browser widths and show a "Refine your search" link
under the breadcrumbs menu. At some point this broke, with the "Refine
your search" link appearing at the bottom instead.

This patch revises the page to restore the previous behavior.

To test, apply the patch and rebuild the OPAC CSS
(https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client).

- Perform catalog search in the OPAC which will return multiple results.
- View the page at various browser widths. At narrower widths the facets
  menu should appear as a "collapsed" box with a "Refine your search"
  link.
- Clicking the link should toggle the facets menu visibility.

Signed-off-by: David Nind <david@davidnind.com>
Comment 3 Katrin Fischer 2022-02-13 14:56:46 UTC
This is blocked by the dependent patch still awaiting sign-off.
Comment 4 Katrin Fischer 2022-02-14 21:21:10 UTC
Back in queue :)
Comment 5 Katrin Fischer 2022-02-14 21:26:17 UTC
Created attachment 130578 [details] [review]
Bug 29603: Fix responsive behavior of facets menu in OPAC search results

The OPAC was originally featured a search results facets box that would
collapse at narrower browser widths and show a "Refine your search" link
under the breadcrumbs menu. At some point this broke, with the "Refine
your search" link appearing at the bottom instead.

This patch revises the page to restore the previous behavior.

To test, apply the patch and rebuild the OPAC CSS
(https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client).

- Perform catalog search in the OPAC which will return multiple results.
- View the page at various browser widths. At narrower widths the facets
  menu should appear as a "collapsed" box with a "Refine your search"
  link.
- Clicking the link should toggle the facets menu visibility.

Signed-off-by: David Nind <david@davidnind.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 6 Fridolin Somers 2022-02-17 07:52:46 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄
Comment 7 David Cook 2022-05-25 23:36:50 UTC
*** Bug 30841 has been marked as a duplicate of this bug. ***
Comment 8 David Cook 2022-05-25 23:38:16 UTC
Btw, this looks like it's needed in 20.11 and 21.11 at least as well.
Comment 9 Owen Leonard 2022-05-26 11:02:07 UTC
Created attachment 135367 [details] [review]
Bug 29603: [21.11.x] Fix responsive behavior of facets menu in OPAC search results

The OPAC was originally featured a search results facets box that would
collapse at narrower browser widths and show a "Refine your search" link
under the breadcrumbs menu. At some point this broke, with the "Refine
your search" link appearing at the bottom instead.

This patch revises the page to restore the previous behavior.

To test, apply the patch and rebuild the OPAC CSS
(https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client).

- Perform catalog search in the OPAC which will return multiple results.
- View the page at various browser widths. At narrower widths the facets
  menu should appear as a "collapsed" box with a "Refine your search"
  link.
- Clicking the link should toggle the facets menu visibility.

Signed-off-by: David Nind <david@davidnind.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 10 Owen Leonard 2022-05-26 11:28:20 UTC
(In reply to Owen Leonard from comment #9)
> Created attachment 135367 [details] [review] [review]
> Bug 29603: [21.11.x] Fix responsive behavior of facets menu in OPAC search
> results

This appears to apply cleanly to 21.05.x too.
Comment 11 Owen Leonard 2022-05-26 11:34:27 UTC Comment hidden (obsolete)
Comment 12 Victor Grousset/tuxayo 2022-10-03 19:19:15 UTC
Note, I got a request for oldoldstable (21.05.x) will try to backport when it will be in oldstable.
Comment 13 Victor Grousset/tuxayo 2022-10-16 02:31:10 UTC
Wait, this has been clearly missed in the last cycle. So it won't happen by itself. Email sent to Arthur for 21.11.x backport.
Comment 14 Arthur Suzuki 2022-11-14 10:28:48 UTC
applied to 21.11.x for 21.11.14
Comment 15 Victor Grousset/tuxayo 2022-11-17 23:47:22 UTC
Backported: Pushed to 21.05.x branch for the upcoming release (21.05.21)

Nothing to document it seems, marking resolved.