Bug 29608 - Editing numbering patterns does require full serials permission
Summary: Editing numbering patterns does require full serials permission
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Serials (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Isobel Graham
QA Contact: Testopia
URL:
Keywords: Academy
: 15201 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-12-01 12:16 UTC by Katrin Fischer
Modified: 2022-11-18 06:32 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.11.00, 22.05.07, 21.11.14


Attachments
Bug 29608: Made so doesn't require full permission (1.03 KB, patch)
2022-09-01 11:41 UTC, Isobel Graham
Details | Diff | Splinter Review
Bug 29608: Made so doesn't require full permission (1.08 KB, patch)
2022-09-02 11:17 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 29608: Made so doesn't require full permission (1.13 KB, patch)
2022-09-03 09:37 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2021-12-01 12:16:43 UTC
There is a mismatch in permission checks for working with serial numbering patterns:

https://git.koha-community.org/Koha-community/Koha/src/branch/master/serials/subscription-numberpatterns.pl 
flagsrequired   => { 'serials' => * }

https://git.koha-community.org/Koha-community/Koha/src/branch/master/serials/subscription-numberpattern.pl
flagsrequired   => { 'serials' => 1 }

I think both shoudl be * and at some point we might want to think of maybe having a separate permission.

The problem is, that this means currently it requires full serials permission or superlibrian to work with the numbering patterns which is not always practical.
Comment 1 Katrin Fischer 2022-01-30 12:19:28 UTC
*** Bug 15201 has been marked as a duplicate of this bug. ***
Comment 2 Isobel Graham 2022-09-01 11:41:53 UTC
Created attachment 140038 [details] [review]
Bug 29608: Made so doesn't require full permission

Made so the numbering sequence does not need to require
full permission.

1. Edit number patterns a confirm you don't need full
permission
Comment 3 Owen Leonard 2022-09-02 11:17:53 UTC
Created attachment 140111 [details] [review]
Bug 29608: Made so doesn't require full permission

Made so the numbering sequence does not need to require full
permission.

1. Edit number patterns a confirm you don't need full permission

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 4 Nick Clemens 2022-09-03 09:37:43 UTC
Created attachment 140194 [details] [review]
Bug 29608: Made so doesn't require full permission

Made so the numbering sequence does not need to require full
permission.

1. Edit number patterns a confirm you don't need full permission

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 5 Tomás Cohen Arazi 2022-09-07 20:58:03 UTC
Pushed to master for 22.11.

Nice work everyone, thanks!
Comment 6 Lucas Gass 2022-10-31 19:57:41 UTC
Backported to 22.05.x for upcoming 22.05.07 release
Comment 7 Arthur Suzuki 2022-11-14 13:32:15 UTC
applied to 21.11.x for 21.11.14
Comment 8 Victor Grousset/tuxayo 2022-11-18 06:32:11 UTC
Not backported to oldoldstable (21.05.x). Feel free to ask if it's needed.

Nothing to document it seems, marking resolved.