Bug 29813 - skeleton.pl missing semicolon
Summary: skeleton.pl missing semicolon
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Tomás Cohen Arazi
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-06 18:27 UTC by Tomás Cohen Arazi
Modified: 2022-01-25 18:00 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.05.00,21.11.02


Attachments
Bug 29813: Add missing semicolon in skeleton.pl (820 bytes, patch)
2022-01-06 18:29 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 29813: Add missing semicolon in skeleton.pl (869 bytes, patch)
2022-01-07 07:30 UTC, David Nind
Details | Diff | Splinter Review
Bug 29813: Add missing semicolon in skeleton.pl (945 bytes, patch)
2022-01-07 15:41 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2022-01-06 18:27:34 UTC

    
Comment 1 Tomás Cohen Arazi 2022-01-06 18:29:56 UTC
Created attachment 129115 [details] [review]
Bug 29813: Add missing semicolon in skeleton.pl

This has no effect as it is not causing problems. But.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 2 David Nind 2022-01-07 07:30:17 UTC
Created attachment 129129 [details] [review]
Bug 29813: Add missing semicolon in skeleton.pl

This has no effect as it is not causing problems. But.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: David Nind <david@davidnind.com>
Comment 3 Jonathan Druart 2022-01-07 15:41:31 UTC
(In reply to Tomás Cohen Arazi from comment #1)
> This has no effect as it is not causing problems. But.

But?
It's not needed if it's the last statement of the block.
Comment 4 Jonathan Druart 2022-01-07 15:41:59 UTC
Created attachment 129191 [details] [review]
Bug 29813: Add missing semicolon in skeleton.pl

This has no effect as it is not causing problems. But.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: David Nind <david@davidnind.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 5 Jonathan Druart 2022-01-07 15:42:20 UTC
It's not a bug IMO, but don't want to argue more than 5 seconds here :D
Comment 6 Fridolin Somers 2022-01-14 07:38:38 UTC
I impacted wiki page 
https://wiki.koha-community.org/wiki/Database_updates#How_to_write_an_atomicupdate_file
Comment 7 Fridolin Somers 2022-01-14 08:12:53 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄
Comment 8 Kyle M Hall 2022-01-14 14:39:44 UTC
Pushed to 21.11.x for 21.11.02
Comment 9 Andrew Fuerste-Henry 2022-01-25 18:00:21 UTC
Not backporting to 21.05, please ask if needed.