Bug 29990 - Show authority heading use in search results
Summary: Show authority heading use in search results
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Authority data support (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Aleisha Amohia
QA Contact: Testopia
URL:
Keywords:
: 26079 (view as bug list)
Depends on:
Blocks: 30501
  Show dependency treegraph
 
Reported: 2022-02-01 02:20 UTC by Aleisha Amohia
Modified: 2022-04-15 11:10 UTC (History)
9 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Authority heading use is based on authority MARC 008/14-16. This could be useful to show on authority search results, if new system preference ShowHeadingUse is enabled.
Version(s) released in:
22.05.00


Attachments
Bug 29990: Add ShowHeadingUse system preference (3.69 KB, patch)
2022-02-01 03:22 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 29990: Show authority appropriate heading use on search results (6.61 KB, patch)
2022-02-01 03:22 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 29990: Show authority appropriate heading use on search results (6.68 KB, patch)
2022-03-10 22:43 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 29990: Show authority appropriate heading use on search results (6.71 KB, patch)
2022-03-11 18:58 UTC, ByWater Sandboxes
Details | Diff | Splinter Review
Bug 29990: Add ShowHeadingUse system preference (3.72 KB, patch)
2022-03-30 13:03 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 29990: Show authority appropriate heading use on search results (6.77 KB, patch)
2022-03-30 13:03 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 29990: (QA follow-up) Change class name and apply to heading, add -x to update (3.60 KB, patch)
2022-03-30 13:03 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 29990: (follow-up) add missing parenthesis (1.80 KB, patch)
2022-04-09 22:40 UTC, Victor Grousset/tuxayo
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Aleisha Amohia 2022-02-01 02:20:39 UTC
In authority records, 008/14-16 consists of characters which indicate what the heading can be used for. It would be useful to display this information in a human-readable way in authority search results.
Comment 1 Aleisha Amohia 2022-02-01 03:22:36 UTC
Created attachment 130034 [details] [review]
Bug 29990: Add ShowHeadingUse system preference
Comment 2 Aleisha Amohia 2022-02-01 03:22:42 UTC
Created attachment 130035 [details] [review]
Bug 29990: Show authority appropriate heading use on search results

Authority heading use is based on authority MARC 008/14-16. This could
be useful to show on authority search results, if new system preference
ShowHeadingUse is enabled.

To test:

1. Apply patches, update database, restart services
2. Go to Koha Administration -> system preferences -> searching tab.
Notice new ShowHeadingUse system preference is disabled. Leave it
disabled for now.
3. Do an authority search. Confirm it works as expected and no new
information is shown since ShowHeadingUse is disabled.
4. Do a biblio search and edit a record. Go to one of the authority
fields (1xx, 6xx or 7xx) and launch the authority finder plugin. Do an
authority search and confirm it works as expected and no new information
is shown since ShowHeadingUse is disabled.
5. Go back to system preferences and enable ShowHeadingUse syspref.
6. Repeat steps 3 and 4 but confirm the 'Heading use' column now shows, and
correctly displays what the heading can be used for based on 008/14-16.

Sponsored-by: Education Services Australia SCIS
Comment 3 Shi Yao Wang 2022-03-10 21:59:52 UTC
Does not apply. Merge conflict: 


Apply? [(y)es, (n)o, (i)nteractive] y
Applying: Bug 29990: Add ShowHeadingUse system preference
Applying: Bug 29990: Show authority appropriate heading use on search results
Using index info to reconstruct a base tree...
M	koha-tmpl/intranet-tmpl/prog/en/modules/authorities/searchresultlist-auth.tt
M	koha-tmpl/intranet-tmpl/prog/en/modules/authorities/searchresultlist.tt
Falling back to patching base and 3-way merge...
Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/authorities/searchresultlist.tt
CONFLICT (content): Merge conflict in koha-tmpl/intranet-tmpl/prog/en/modules/authorities/searchresultlist.tt
Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/authorities/searchresultlist-auth.tt
error: Failed to merge in the changes.
Patch failed at 0001 Bug 29990: Show authority appropriate heading use on search results
Comment 4 Aleisha Amohia 2022-03-10 22:43:44 UTC
Created attachment 131583 [details] [review]
Bug 29990: Show authority appropriate heading use on search results

Authority heading use is based on authority MARC 008/14-16. This could
be useful to show on authority search results, if new system preference
ShowHeadingUse is enabled.

To test:

1. Apply patches, update database, restart services
2. Go to Koha Administration -> system preferences -> searching tab.
Notice new ShowHeadingUse system preference is disabled. Leave it
disabled for now.
3. Do an authority search. Confirm it works as expected and no new
information is shown since ShowHeadingUse is disabled.
4. Do a biblio search and edit a record. Go to one of the authority
fields (1xx, 6xx or 7xx) and launch the authority finder plugin. Do an
authority search and confirm it works as expected and no new information
is shown since ShowHeadingUse is disabled.
5. Go back to system preferences and enable ShowHeadingUse syspref.
6. Repeat steps 3 and 4 but confirm the 'Heading use' column now shows, and
correctly displays what the heading can be used for based on 008/14-16.

Sponsored-by: Education Services Australia SCIS
Comment 5 ByWater Sandboxes 2022-03-11 18:58:50 UTC
Created attachment 131617 [details] [review]
Bug 29990: Show authority appropriate heading use on search results

Authority heading use is based on authority MARC 008/14-16. This could
be useful to show on authority search results, if new system preference
ShowHeadingUse is enabled.

To test:

1. Apply patches, update database, restart services
2. Go to Koha Administration -> system preferences -> searching tab.
Notice new ShowHeadingUse system preference is disabled. Leave it
disabled for now.
3. Do an authority search. Confirm it works as expected and no new
information is shown since ShowHeadingUse is disabled.
4. Do a biblio search and edit a record. Go to one of the authority
fields (1xx, 6xx or 7xx) and launch the authority finder plugin. Do an
authority search and confirm it works as expected and no new information
is shown since ShowHeadingUse is disabled.
5. Go back to system preferences and enable ShowHeadingUse syspref.
6. Repeat steps 3 and 4 but confirm the 'Heading use' column now shows, and
correctly displays what the heading can be used for based on 008/14-16.

Sponsored-by: Education Services Australia SCIS

Signed-off-by: Jessica <jzairo@bywatersolutions.com>
Comment 6 Kelly McElligott 2022-03-11 19:00:21 UTC
Works as Explained- signed off.
Comment 7 Alex Buckley 2022-03-30 01:22:33 UTC
*** Bug 26079 has been marked as a duplicate of this bug. ***
Comment 8 Nick Clemens 2022-03-30 13:03:37 UTC
Created attachment 132606 [details] [review]
Bug 29990: Add ShowHeadingUse system preference

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 9 Nick Clemens 2022-03-30 13:03:42 UTC
Created attachment 132607 [details] [review]
Bug 29990: Show authority appropriate heading use on search results

Authority heading use is based on authority MARC 008/14-16. This could
be useful to show on authority search results, if new system preference
ShowHeadingUse is enabled.

To test:

1. Apply patches, update database, restart services
2. Go to Koha Administration -> system preferences -> searching tab.
Notice new ShowHeadingUse system preference is disabled. Leave it
disabled for now.
3. Do an authority search. Confirm it works as expected and no new
information is shown since ShowHeadingUse is disabled.
4. Do a biblio search and edit a record. Go to one of the authority
fields (1xx, 6xx or 7xx) and launch the authority finder plugin. Do an
authority search and confirm it works as expected and no new information
is shown since ShowHeadingUse is disabled.
5. Go back to system preferences and enable ShowHeadingUse syspref.
6. Repeat steps 3 and 4 but confirm the 'Heading use' column now shows, and
correctly displays what the heading can be used for based on 008/14-16.

Sponsored-by: Education Services Australia SCIS

Signed-off-by: Jessica <jzairo@bywatersolutions.com>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 10 Nick Clemens 2022-03-30 13:03:46 UTC
Created attachment 132608 [details] [review]
Bug 29990: (QA follow-up) Change class name and apply to heading, add -x to update

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 11 Fridolin Somers 2022-04-08 13:53:13 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄
Comment 12 Victor Grousset/tuxayo 2022-04-09 22:35:24 UTC
Master broken due to "Add ShowHeadingUse system preference"
Missing closing parenthesis.
Comment 13 Victor Grousset/tuxayo 2022-04-09 22:40:58 UTC
Created attachment 133128 [details] [review]
Bug 29990: (follow-up) add missing parenthesis
Comment 14 Martin Renvoize 2022-04-11 11:49:11 UTC
Lucas also added the fix in bug 30501.. I QA'd is there to make sure it doesn't get held up in any way..
Comment 15 Fridolin Somers 2022-04-11 13:31:23 UTC
Comment on attachment 133128 [details] [review]
Bug 29990: (follow-up) add missing parenthesis

Fixed by Bug 30501