We've started adding a few search_limited methods to Koha::PluralClass objects to limit searches to only return patron related rows the current logged in user should be allowed to see. We should a) rename search_limited to search_with_patron_limits (to match search_with_library_limits that already exists) and b) DRY out the code along the lines of Koha::Objects::Limit::Library.
Should these actually be.. * filter_by_library_limits * filter_by_patron_limits and * filter_by_accessible (combining both the above)