Bug 30101 - OPAC advanced search page broken by Bug 29844
Summary: OPAC advanced search page broken by Bug 29844
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Fridolin Somers
QA Contact: Testopia
URL:
Keywords:
: 30091 (view as bug list)
Depends on: 29844
Blocks:
  Show dependency treegraph
 
Reported: 2022-02-14 19:31 UTC by Owen Leonard
Modified: 2022-02-18 11:49 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.05.00


Attachments
Bug 30101: Fix OPAC advanced search after Bug 29844 (1.16 KB, patch)
2022-02-14 20:28 UTC, Fridolin Somers
Details | Diff | Splinter Review
Bug 30101: Fix OPAC advanced search after Bug 29844 (1.21 KB, patch)
2022-02-14 20:43 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 30101: Fix OPAC advanced search after Bug 29844 (1.29 KB, patch)
2022-02-15 07:25 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2022-02-14 19:31:24 UTC
Template process failed: undef error - The method Koha::Library::Groups->id is not covered by tests!

Trace begun at /kohadevbox/koha/Koha/Objects.pm line 572
Koha::Objects::AUTOLOAD('Koha::Library::Groups=HASH(0x5576ff179cc8)') called at /kohadevbox/koha/koha-tmpl/opac-tmpl/bootstrap/en/modules/opac-advsearch.tt line 253
Comment 1 Fridolin Somers 2022-02-14 20:28:16 UTC
Created attachment 130570 [details] [review]
Bug 30101: Fix OPAC advanced search after Bug 29844

Bug 29844 forgot to add as_list to opac-search.pl.
You can see it changed search.pl

Patch fixes and also adds explicit interface = opac in get_search_groups() call.
Since intranet is explicit, opac should also be.
We keep opac as default value.

Test plan :
1) Create a libary group for OPAC and one for staff
2) Go to OPAC advanced search page
3) Check you see the OPAC libary group
Comment 2 Katrin Fischer 2022-02-14 20:41:35 UTC
*** Bug 30091 has been marked as a duplicate of this bug. ***
Comment 3 Katrin Fischer 2022-02-14 20:43:32 UTC
Created attachment 130572 [details] [review]
Bug 30101: Fix OPAC advanced search after Bug 29844

Bug 29844 forgot to add as_list to opac-search.pl.
You can see it changed search.pl

Patch fixes and also adds explicit interface = opac in get_search_groups() call.
Since intranet is explicit, opac should also be.
We keep opac as default value.

Test plan :
1) Create a libary group for OPAC and one for staff
2) Go to OPAC advanced search page
3) Check you see the OPAC libary group

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 4 Jonathan Druart 2022-02-15 07:25:56 UTC
Created attachment 130590 [details] [review]
Bug 30101: Fix OPAC advanced search after Bug 29844

Bug 29844 forgot to add as_list to opac-search.pl.
You can see it changed search.pl

Patch fixes and also adds explicit interface = opac in get_search_groups() call.
Since intranet is explicit, opac should also be.
We keep opac as default value.

Test plan :
1) Create a libary group for OPAC and one for staff
2) Go to OPAC advanced search page
3) Check you see the OPAC libary group

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 5 Fridolin Somers 2022-02-16 21:52:48 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄