Bug 30120 - Allow extended attributes during self registration when using PatronSelfRegistrationVerifyByEmail
Summary: Allow extended attributes during self registration when using PatronSelfRegis...
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Nick Clemens
QA Contact: Testopia
URL:
Keywords:
: 30040 (view as bug list)
Depends on: 26119
Blocks:
  Show dependency treegraph
 
Reported: 2022-02-17 14:02 UTC by Nick Clemens
Modified: 2022-04-15 10:39 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.05.00


Attachments
Bug 30120: Save and apply extended attributes during self registration verification by email (5.31 KB, patch)
2022-02-17 14:06 UTC, Nick Clemens
Details | Diff | Splinter Review
Bug 30120: Save and apply extended attributes during self registration verification by email (5.36 KB, patch)
2022-02-17 15:03 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 30120: Save and apply extended attributes during self registration verification by email (5.42 KB, patch)
2022-03-27 13:09 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2022-02-17 14:02:28 UTC

    
Comment 1 Nick Clemens 2022-02-17 14:06:52 UTC
Created attachment 130748 [details] [review]
Bug 30120: Save and apply extended attributes during self registration verification by email

The self registration form stores a new borrower as a borrower modification when verifying by email.

Borrower modifications can  handle extended attributes.

This patch simply sotres the extended attributes in the modifications table, and approves a modification
to the extended attributes only after patron is created

To test:
1 - Apply patch
2 - Create a patron attribute and set it as viewable/editable in the OPAC
3 - Set system preference PatronSelfRegistrationVerifyByEmail
4 - Reigster a new patron on the OPAC, provide an email and populate the extended attribute
5 - Retrieve the verification token, the last on in the messages table
    SELECT * FROM message_queue;
6 - Go tot he url from above
7 - Confirm successful patron creation
8 - View patron record and confirm attribute was set
Comment 2 Nick Clemens 2022-02-17 14:07:58 UTC
*** Bug 30040 has been marked as a duplicate of this bug. ***
Comment 3 Lucas Gass 2022-02-17 15:03:20 UTC
Created attachment 130750 [details] [review]
Bug 30120: Save and apply extended attributes during self registration verification by email

The self registration form stores a new borrower as a borrower modification when verifying by email.

Borrower modifications can  handle extended attributes.

This patch simply sotres the extended attributes in the modifications table, and approves a modification
to the extended attributes only after patron is created

To test:
1 - Apply patch
2 - Create a patron attribute and set it as viewable/editable in the OPAC
3 - Set system preference PatronSelfRegistrationVerifyByEmail
4 - Reigster a new patron on the OPAC, provide an email and populate the extended attribute
5 - Retrieve the verification token, the last on in the messages table
    SELECT * FROM message_queue;
6 - Go tot he url from above
7 - Confirm successful patron creation
8 - View patron record and confirm attribute was set

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>
Comment 4 Katrin Fischer 2022-03-27 13:09:06 UTC
Created attachment 132273 [details] [review]
Bug 30120: Save and apply extended attributes during self registration verification by email

The self registration form stores a new borrower as a borrower modification when verifying by email.

Borrower modifications can  handle extended attributes.

This patch simply sotres the extended attributes in the modifications table, and approves a modification
to the extended attributes only after patron is created

To test:
1 - Apply patch
2 - Create a patron attribute and set it as viewable/editable in the OPAC
3 - Set system preference PatronSelfRegistrationVerifyByEmail
4 - Reigster a new patron on the OPAC, provide an email and populate the extended attribute
5 - Retrieve the verification token, the last on in the messages table
    SELECT * FROM message_queue;
6 - Go tot he url from above
7 - Confirm successful patron creation
8 - View patron record and confirm attribute was set

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Fridolin Somers 2022-04-08 13:53:34 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄