Bug 30272 - When creating a new HTML customization if you don't include a title the HTML customization will not be created
Summary: When creating a new HTML customization if you don't include a title the HTML ...
Status: RESOLVED DUPLICATE of bug 29782
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on: 29515
Blocks:
  Show dependency treegraph
 
Reported: 2022-03-10 21:06 UTC by Lucas Gass
Modified: 2022-08-16 12:00 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lucas Gass 2022-03-10 21:06:06 UTC
To recreate:


1. Go to Tools > News and create a new HTML customization
2. Omit the title as it should not be required
3. You will be directed back to /cgi-bin/koha/tools/additional-contents.pl but the HTML customization is not created
4. "select * from additional_contents;"
5. It isn't there.

This does not effect News, only HTML customization, as News still requires a title.
Comment 1 Katrin Fischer 2022-03-10 22:23:19 UTC
Have you tried adding content too? I feel like we had tested that, but there was a separate problem with the content not being added if the default entry was empty... bug 29828
Comment 2 Katrin Fischer 2022-03-10 22:23:44 UTC
I really think we need this to be a bit more robust overall.
Comment 3 Lucas Gass 2022-03-10 22:31:30 UTC
(In reply to Katrin Fischer from comment #1)
> Have you tried adding content too? I feel like we had tested that, but there
> was a separate problem with the content not being added if the default entry
> was empty... bug 29828

This problem still occurs if you add content. It also doesn't matter if you use CodeMirror or TinyMCE, the result is the same and no HTML customization is added.
Comment 4 Marcel de Rooy 2022-08-16 12:00:20 UTC
I am submitting a fix on 29782 that also resolves this one.
It is not really a duplicate but a similar issue..

*** This bug has been marked as a duplicate of bug 29782 ***