Bug 30355 - SMS auto renew digest notices are only generated if patron is also set to receive email
Summary: SMS auto renew digest notices are only generated if patron is also set to rec...
Status: RESOLVED DUPLICATE of bug 28553
Alias: None
Product: Koha
Classification: Unclassified
Component: Notices (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
Depends on: 28553
Blocks:
  Show dependency treegraph
 
Reported: 2022-03-24 14:53 UTC by Andrew Fuerste-Henry
Modified: 2022-09-13 13:33 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 28553: Patrons can be set to receive auto_renew notices as SMS, but Koha does not generate them (6.77 KB, patch)
2022-07-18 16:40 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Fuerste-Henry 2022-03-24 14:53:44 UTC
To recreate:
- set AutoRenewalNotices to follow messaging prefs
- confirm your AUTO_RENEWALS_DGST letter has email and SMS content
- set up a borrower with messaging prefs to receive AUTO_RENEWALS_DGST via SMS only and an item ready for auto-renew
- set up a second borrower with messaging prefs to receive AUTO_RENEWALS_DGST via both email and SMS and an item read for auto-renew
- run the auto-renew cron
- confirm your first patron received no notice while your second patron received both email and SMS
Comment 1 Kyle M Hall 2022-07-18 16:40:22 UTC
Created attachment 137829 [details] [review]
Bug 28553: Patrons can be set to receive auto_renew notices as SMS, but Koha does not generate them

Following bug 18532, one can set a patron's messaging prefs to deliver an auto-renew notice via SMS.
However, the auto_renewals cron only knows how to generate email notices. We should not allow the selection of non-functional transport types.

Test Plan:
1) Set a patron to recieve auto-renewals via SMS, leave digest mode
   disabled. Ensure no other transports are enabled either.
2) Auto-renew some items
3) Note the SMS auto-renewal notice was generated!
Comment 2 David Cook 2022-09-13 05:57:07 UTC
I think that we can just close this one as a duplicate of bug 28553. 

Happy with that, Andrew?
Comment 3 David Cook 2022-09-13 06:44:21 UTC

*** This bug has been marked as a duplicate of bug 28553 ***
Comment 4 Andrew Fuerste-Henry 2022-09-13 13:33:06 UTC
(In reply to David Cook from comment #2)
> I think that we can just close this one as a duplicate of bug 28553. 
> 
> Happy with that, Andrew?

Good catch, thanks David!