Bug 3042 - Add more details to OPAC search results RSS
Summary: Add more details to OPAC search results RSS
Status: CLOSED MOVED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Owen Leonard
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-17 10:07 UTC by Owen Leonard
Modified: 2012-10-26 00:41 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed fix. (7.04 KB, patch)
2009-03-17 10:15 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:05:43 UTC


---- Reported by oleonard@myacpl.org 2009-03-17 10:07:59 ----

Currently the OPAC search results RSS (opac-opensearch.pl/.tmpl) displays only title and, curiously, number of pages. This should be expanded to better match the details shown in the regular search results.



---- Additional Comments From oleonard@myacpl.org 2009-03-17 10:15:30 ----

Created an attachment
Proposed fix.

The proposed fix also includes a change to Search.pm to add a variable, subtitle_nospan, in order
 to display subtitles in the feed without search term highlighting HTML. The mod
ified template attempts to display Amazon or Baker & Taylor book cover images. G
oogle images are not included because they require Javascript.



---- Additional Comments From oleonard@myacpl.org 2009-04-02 16:30:50 ----



*** This bug has been marked as a duplicate of http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2973 ***



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:05 UTC  ---

This bug was previously known as _bug_ 3042 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3042
Imported an attachment (id=1044)

Actual time not defined. Setting to 0.0
This bug was marked DUPLICATE in the database it was moved from.
    Changing resolution to "MOVED"
The original submitter of attachment 1044 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.