Bug 30620 - Add a warning close to /*!VERSION lines in kohastructure.sql
Summary: Add a warning close to /*!VERSION lines in kohastructure.sql
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Database (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Marcel de Rooy
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-26 11:30 UTC by Marcel de Rooy
Modified: 2022-06-23 13:50 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact: Martin Renvoize
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.05.00,21.11.06


Attachments
Bug 30620: Add a warning about /*!VERSION lines in kohastructure (1.91 KB, patch)
2022-04-26 12:02 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 30620: Add a warning about /*!VERSION lines in kohastructure (1.94 KB, patch)
2022-04-26 13:38 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2022-04-26 11:30:04 UTC
These first lines in kohastructure are just ignored by DBIx::RunSQL.
They could serve a purpose however when running the file directly on the sql command line.
So we should at least add a comment to warn people.
On bug 26947 some of these settings are taken over in C4::Installer::load_db_schema.
Comment 1 Marcel de Rooy 2022-04-26 12:02:36 UTC
Created attachment 133876 [details] [review]
Bug 30620: Add a warning about /*!VERSION lines in kohastructure

Also adding a similar comment in C4::Installer.

No test plan, just documentation.

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 2 Marcel de Rooy 2022-04-26 12:03:01 UTC
Trivial: self SO
Comment 3 Marcel de Rooy 2022-04-26 12:03:32 UTC
QA should be trivial too ?
Comment 4 Martin Renvoize 2022-04-26 13:38:02 UTC
Created attachment 133898 [details] [review]
Bug 30620: Add a warning about /*!VERSION lines in kohastructure

Also adding a similar comment in C4::Installer.

No test plan, just documentation.

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 5 Martin Renvoize 2022-04-26 13:39:35 UTC
Trivial improvement, Passing QA.

Note however that we will need to consider the .SQL file change as if we start to use koha-dump to generate the structure file regularly (to keep updatedatabase and the kohastrucutre files in sync as intended) it will wipe out the change here.
Comment 6 Jonathan Druart 2022-04-28 08:38:40 UTC
Not a good idea, kohastructure.sql will be regenerated at the next major release.
Comment 7 Fridolin Somers 2022-05-02 21:25:55 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄
Comment 8 Kyle M Hall 2022-05-13 15:51:03 UTC
Pushed to 21.11.x for 21.11.06
Comment 9 Victor Grousset/tuxayo 2022-06-23 01:45:45 UTC
Not backported to oldoldstable (21.05.x). Feel free to ask if it's needed.
Comment 10 Martin Renvoize 2022-06-23 13:50:52 UTC
Documentation for developers/administrators.. no wider documentation change is required.