Bug 3072 - 'Heading-Main' authority-index breaks authority searching in STABLE
Summary: 'Heading-Main' authority-index breaks authority searching in STABLE
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) critical (vote)
Assignee: Jared Camins-Esakov
QA Contact: Bugs List
URL:
Keywords:
: 3429 6128 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-29 01:23 UTC by Chris Cormack
Modified: 2019-06-27 09:24 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
temporary patch (1.09 KB, patch)
2009-04-02 05:02 UTC, Chris Cormack
Details | Diff | Splinter Review
Patch (1.88 KB, patch)
2011-02-18 13:59 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Revised patch (1.84 KB, patch)
2011-04-06 12:57 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Signed off patch (1.91 KB, patch)
2011-04-07 09:43 UTC, Katrin Fischer
Details | Diff | Splinter Review
Follow-up patch (10.06 KB, patch)
2011-04-09 13:05 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Revised follow-up patch (16.35 KB, patch)
2011-04-09 14:56 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Revised follow-up patch, adding the Any index (17.54 KB, patch)
2011-04-11 14:06 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
signed off follow up (17.99 KB, patch)
2011-04-18 12:27 UTC, Nicole C. Engard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:06:04 UTC


---- Reported by mason@kohaaloha.com 2009-03-29 13:23:47 ----

this is the problem commit...
http://git.koha.org/cgi-bin/gitweb.cgi?p=Koha;a=commit;h=8cd4d221d880da21a1d2c5d83fac792934f1c87e

currently (on my MARC21 kohas) most 'default' auth-searches return with 'no results', glitchy pagination, and this error below...

"authorities-home.pl: oAuth error: Unsupported Use attribute (114) Heading-Main Bib-1"

this commit looks to be a partially committed feature. And i suspect breaks both UNIMARC and MARC21. (i have only tested MARC21)

the quick fix for this (for MARC21 at least), is to change 'heading-main' back to 'heading', as below.
then search results will be returned as expected.


--- a/C4/AuthoritiesMarc.pm
+++ b/C4/AuthoritiesMarc.pm
@@ -223,7 +223,7 @@ sub SearchAuthorities {
             if (@$value[$i]){
             ##If mainentry search $a tag
                 if (@$tags[$i] eq "mainmainentry") {
-                $attr =" \@attr 1=Heading ";
+                $attr =" \@attr 1=Heading-Main ";    <<<<<<<<<<<<<< OOPS
                 }elsif (@$tags[$i] eq "mainentry") {
                 $attr =" \@attr 1=Heading ";
                 }else{


my assumption is that the new 'Heading-Main' index needs to be correctly defined in all these files below, before it will work???.

./authorities/etc/bib1.att
./ccl.properties
./marc_defs/unimarc/authorities/record.abs
./marc_defs/marc21/authorities/record.abs
./marc_defs/marc21/authorities/authority-koha-indexdefs.xml
./marc_defs/marc21/authorities/authority-zebra-indexdefs.xsl

any ideas Folks??



---- Additional Comments From mason@kohaaloha.com 2009-04-02 05:02:42 ----

Created an attachment
temporary patch





---- Additional Comments From colin.campbell@ptfs-europe.com 2009-04-02 08:01:29 ----

See also 3052



---- Additional Comments From gmcharlt@gmail.com 2009-04-25 03:07:05 ----

*** http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3052 has been marked as a duplicate of this bug. ***



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:06 UTC  ---

This bug was previously known as _bug_ 3072 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3072
Imported an attachment (id=1069)

Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was mason@kohaaloha.com.
The original submitter of attachment 1069 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Marcel de Rooy 2011-02-17 14:27:23 UTC
*** Bug 3429 has been marked as a duplicate of this bug. ***
Comment 2 Marcel de Rooy 2011-02-18 13:52:04 UTC
Sending a patch that includes Heading-Main in authorities bib1 attribute set.
Also includes Any in authorities bib1 (was still missing).
Also removes temporary fix in AuthoritiesMarc.pm.

Please test this patch in 
1) OPAC Authorities search: Search in authorities on all three options ($a, main entry, anywhere). Can you get different numbers in all three searches? To have a difference between the first two results, you may have to add your search expression in a $b field somewhere, update zebra and run again.
2) Do the same three searches in Staff Authorities. Search Authorities is looking in $a only, the middle one Main Heading looks in all 1XX fields, the last one looks anywhere.
Comment 3 Marcel de Rooy 2011-02-18 13:59:25 UTC Comment hidden (obsolete)
Comment 4 Frederic Durand 2011-04-06 08:04:36 UTC
Patch from Bug 5924 seems to resolve this one too.
Comment 5 Chris Cormack 2011-04-06 08:24:01 UTC
Patch pushed for 5924 is said to fix this as well, please test
Comment 6 Marcel de Rooy 2011-04-06 12:20:36 UTC
(In reply to comment #5)
> Patch pushed for 5924 is said to fix this as well, please test

DO not completely agree. Patch 3072 was more complete.
Sending follow up fix for it.
Setting status back to signed.
Comment 7 Marcel de Rooy 2011-04-06 12:57:07 UTC Comment hidden (obsolete)
Comment 8 Marcel de Rooy 2011-04-07 06:24:28 UTC
(In reply to comment #4)
> Patch from Bug 5924 seems to resolve this one too.

Could you signoff this patch please? It resolves the MARC21 situation. UNIMARC works fine.
Comment 9 Katrin Fischer 2011-04-07 09:43:20 UTC
Created attachment 3775 [details] [review]
Signed off patch

Tested different search and lots of authority records. Looks good to me!
Comment 10 Chris Cormack 2011-04-07 23:28:28 UTC
Pushed please test
Comment 11 Ian Walls 2011-04-08 14:42:21 UTC
This patch does not cover DOM authorities
Comment 12 Marcel de Rooy 2011-04-08 17:35:24 UTC
(In reply to comment #11)
> This patch does not cover DOM authorities

Please explain: authorities-dom.cfg refers to bib1.att. This patch adds Heading-Main to bib1.att. So what is not covered exactly?
Comment 13 Ian Walls 2011-04-08 17:49:25 UTC
./marc_defs/marc21/authorities/authority-koha-indexdefs.xml
./marc_defs/marc21/authorities/authority-zebra-indexdefs.xsl

are both uncovered, and they are the DOM equivalents for record.abs (or a translation mechanism, I can't really tell)  In truth, it's the patch for 5924 that does the actual breaking, since it changes SearchAuthorities to use "Heading-Main" instead of "Heading" for 'mainmainentry' marclinks.  bib1.att is just fine.
Comment 14 Marcel de Rooy 2011-04-08 18:01:28 UTC
(In reply to comment #13)
> ./marc_defs/marc21/authorities/authority-koha-indexdefs.xml
> ./marc_defs/marc21/authorities/authority-zebra-indexdefs.xsl
> are both uncovered, and they are the DOM equivalents for record.abs (or a
> translation mechanism, I can't really tell)  In truth, it's the patch for 5924
> that does the actual breaking, since it changes SearchAuthorities to use
> "Heading-Main" instead of "Heading" for 'mainmainentry' marclinks.  bib1.att is
> just fine.

Thanks. It seems that we should add Heading-Main in these two files also. Can take a look Monday..
Comment 15 Jared Camins-Esakov 2011-04-09 13:05:21 UTC Comment hidden (obsolete)
Comment 16 Jared Camins-Esakov 2011-04-09 13:05:52 UTC
Note that the first patch has already been signed off, and it is only the follow-up patch that requires sign-off.
Comment 17 Jared Camins-Esakov 2011-04-09 13:23:55 UTC
*** Bug 6128 has been marked as a duplicate of this bug. ***
Comment 18 Jared Camins-Esakov 2011-04-09 14:56:09 UTC Comment hidden (obsolete)
Comment 19 Jared Camins-Esakov 2011-04-11 14:06:14 UTC
Created attachment 3864 [details] [review]
Revised follow-up patch, adding the Any index

This revised patch adds both Heading-Main and Any indexes to the DOM MARC21 Authorities configuration.
Comment 20 Jared Camins-Esakov 2011-04-12 12:23:00 UTC
Re-assigning to me since marcelr's patch was pushed, and I'm responsible for the proposed fix for MARC21 DOM authorities.
Comment 21 Nicole C. Engard 2011-04-18 12:27:25 UTC
follow up signed off
Comment 22 Nicole C. Engard 2011-04-18 12:27:49 UTC
Created attachment 3937 [details] [review]
signed off follow up
Comment 23 Chris Cormack 2011-04-19 01:03:27 UTC
Follow up pushed, please test
Comment 24 Jared Camins-Esakov 2011-07-08 14:33:51 UTC
This seems to be working to me. I'm going to close. Reopen if there's a problem.