Bug 3075 - return to search results on detail page
Summary: return to search results on detail page
Status: CLOSED DUPLICATE of bug 6483
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: PC All
: P5 - low minor with 31 votes (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-31 10:03 UTC by Nicole C. Engard
Modified: 2012-10-26 00:40 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:06:06 UTC


---- Reported by nengard@gmail.com 2009-03-31 10:03:52 ----

The fact that you have to use the browser back button to return to search results from the detail page in the OPAC goes against most usability rules.  Can we add a link to return to search results?



---- Additional Comments From oleonard@myacpl.org 2009-03-31 12:20:00 ----

I like the idea, but I'm not sure how to accomplish it. How do we pass the last search to the detail page? A URL parameter? A session variable of some kind? Do you try to remember the last search through other steps like moving from the detail page to the MARC view?



---- Additional Comments From nengard@gmail.com 2009-03-31 15:52:46 ----

Why not just do a link that calls the javascript back function - that sends your browser back?



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:06 UTC  ---

This bug was previously known as _bug_ 3075 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3075

Actual time not defined. Setting to 0.0
CC member bchurch@ptfs.com does not have an account here

Comment 1 Owen Leonard 2010-05-28 15:09:04 UTC
> The fact that you have to use the browser back button to return to search
> results from the detail page in the OPAC goes against most usability rules. 
...
> Why not just do a link that calls the javascript back function - that sends
> your browser back?

Offering a link to the user which calls history.back() seems to mask the problem that we're not leveraging any built-in method for tracking a user's last search task. What happens if I click from the normal view to the MARC view, and then I want to go back to the search results? I can click the "return to search" link, but it will end up sending me to the detail page.

And that's leaving aside the fact that a solution based on javascript isn't a universal one. 

But hey, we have an OPAC search history feature now--how can we make that work to fix this bug?
Comment 2 Nicole C. Engard 2010-05-28 19:21:50 UTC
Now we just need someone to tap into that search history to put the 'back to results' link on the bib record - because that's where patrons are looking for it :) not in 'search history'
Comment 3 Owen Leonard 2011-10-27 16:46:54 UTC

*** This bug has been marked as a duplicate of bug 6483 ***